aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/linux/ath79/dts/ar9342_zyxel_nwa1100-nh.dts46
-rw-r--r--target/linux/ath79/generic/base-files/etc/board.d/01_leds3
-rw-r--r--target/linux/ath79/generic/base-files/etc/board.d/02_network1
-rw-r--r--target/linux/ath79/image/generic.mk8
4 files changed, 58 insertions, 0 deletions
diff --git a/target/linux/ath79/dts/ar9342_zyxel_nwa1100-nh.dts b/target/linux/ath79/dts/ar9342_zyxel_nwa1100-nh.dts
new file mode 100644
index 0000000000..fd438059e5
--- /dev/null
+++ b/target/linux/ath79/dts/ar9342_zyxel_nwa1100-nh.dts
@@ -0,0 +1,46 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "ar9342_zyxel_nwa11xx.dtsi"
+
+/ {
+ compatible = "zyxel,nwa1100-nh", "qca,ar9342";
+ model = "Zyxel NWA1100-NH";
+
+ aliases {
+ label-mac-device = &eth0;
+ led-boot = &led_status_green;
+ led-failsafe = &led_status_red;
+ led-running = &led_status_green;
+ led-upgrade = &led_status_red;
+ };
+ leds {
+ compatible = "gpio-leds";
+
+ led_status_green: status_green {
+ label = "green:status";
+ gpios = <&gpio 12 GPIO_ACTIVE_HIGH>;
+ default-state = "on";
+ };
+
+ led_status_red: status_red {
+ label = "red:status";
+ gpios = <&gpio 11 GPIO_ACTIVE_LOW>;
+ };
+
+ led_wlan_green: wlan_green {
+ label = "green:wlan";
+ gpios = <&gpio 15 GPIO_ACTIVE_LOW>;
+ linux,default-trigger = "phy0tpt";
+ };
+
+ led_lan_green: lan_green {
+ label = "green:lan";
+ gpios = <&gpio 13 GPIO_ACTIVE_LOW>;
+ };
+
+ led_lan_amber: lan_amber {
+ label = "amber:lan";
+ gpios = <&gpio 17 GPIO_ACTIVE_LOW>;
+ };
+ };
+};
diff --git a/target/linux/ath79/generic/base-files/etc/board.d/01_leds b/target/linux/ath79/generic/base-files/etc/board.d/01_leds
index b3a8b2fbb6..188262018c 100644
--- a/target/linux/ath79/generic/base-files/etc/board.d/01_leds
+++ b/target/linux/ath79/generic/base-files/etc/board.d/01_leds
@@ -484,6 +484,9 @@ zbtlink,zbt-wd323)
ucidef_set_led_switch "lan1" "LAN1" "orange:lan1" "switch0" "0x10"
ucidef_set_led_switch "lan2" "LAN2" "orange:lan2" "switch0" "0x08"
;;
+zyxel,nwa1100-nh)
+ ucidef_set_led_netdev "lan_data" "LAN_DATA" "amber:lan" "eth0" "tx rx"
+ ucidef_set_led_netdev "lan_link" "LAN_LINK" "green:lan" "eth0" "link"
esac
board_config_flush
diff --git a/target/linux/ath79/generic/base-files/etc/board.d/02_network b/target/linux/ath79/generic/base-files/etc/board.d/02_network
index 9656c009a1..c576dacee5 100644
--- a/target/linux/ath79/generic/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/generic/base-files/etc/board.d/02_network
@@ -110,6 +110,7 @@ ath79_setup_interfaces()
ubnt,unifi|\
wd,mynet-wifi-rangeextender|\
winchannel,wb2000|\
+ zyxel,nwa1100-nh|\
zyxel,nwa1121-ni|\
zyxel,nwa1123-ac|\
zyxel,nwa1123-ni)
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 612b79f8d6..575004ea15 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -2708,6 +2708,14 @@ define Device/zyxel_nwa11xx
vmlinux_mi124_f1e mi124_f1e-jffs2 | append-md5sum-bin
endef
+define Device/zyxel_nwa1100-nh
+ $(Device/zyxel_nwa11xx)
+ DEVICE_MODEL := NWA1100
+ DEVICE_VARIANT := NH
+ ZYXEL_MODEL_STRING := AASI
+endef
+TARGET_DEVICES += zyxel_nwa1100-nh
+
define Device/zyxel_nwa1121-ni
$(Device/zyxel_nwa11xx)
DEVICE_MODEL := NWA1121