aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/linux/apm821xx/dts/netgear-wndap6x0.dtsi10
-rw-r--r--target/linux/apm821xx/image/nand.mk5
2 files changed, 9 insertions, 6 deletions
diff --git a/target/linux/apm821xx/dts/netgear-wndap6x0.dtsi b/target/linux/apm821xx/dts/netgear-wndap6x0.dtsi
index fc428bca0f..88284d0237 100644
--- a/target/linux/apm821xx/dts/netgear-wndap6x0.dtsi
+++ b/target/linux/apm821xx/dts/netgear-wndap6x0.dtsi
@@ -61,12 +61,12 @@
* offset (0x110000) for an uImage binary.
*/
label = "kernel";
- reg = <0x00110000 0x003f0000>;
+ reg = <0x00110000 0x005f0000>;
};
- partition@500000 {
+ partition@700000 {
label = "ubi";
- reg = <0x00500000 0x016d0000>;
+ reg = <0x00700000 0x014d0000>;
};
partition@1bd0000 {
@@ -83,13 +83,13 @@
partition@1be0000 {
label = "var";
- reg = <0x01be0000 0x0400000>;
+ reg = <0x01be0000 0x00400000>;
read-only;
};
partition@1fe0000 {
label = "manudata";
- reg = <0x01fe0000 0x20000 >;
+ reg = <0x01fe0000 0x00020000>;
read-only;
};
};
diff --git a/target/linux/apm821xx/image/nand.mk b/target/linux/apm821xx/image/nand.mk
index 26676c8d8b..76b1386241 100644
--- a/target/linux/apm821xx/image/nand.mk
+++ b/target/linux/apm821xx/image/nand.mk
@@ -68,11 +68,14 @@ define Device/netgear_wndap6x0
DTB_SIZE := 32768
IMAGE_SIZE := 27392k
IMAGES := sysupgrade.bin factory.img
- KERNEL_SIZE := 4032k
+ KERNEL_SIZE := 6080k
KERNEL := dtb | kernel-bin | gzip | MuImage-initramfs gzip
IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
IMAGE/factory.img := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
UBINIZE_OPTS := -E 5
+ DEVICE_COMPAT_VERSION := 2.0
+ DEVICE_COMPAT_MESSAGE := kernel and ubi partitions had to be resized. \
+ Upgrade via sysupgrade mechanism is not possible.
endef
define Device/netgear_wndap620