aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/host-build.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index 22fcc31f15..2cc1ec5842 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -206,5 +206,9 @@ endif
define HostBuild
$(HostBuild/Core)
- $(if $(if $(PKG_HOST_ONLY),,$(if $(and $(filter host-%,$(MAKECMDGOALS)),$(PKG_SKIP_DOWNLOAD)),,$(STAMP_PREPARED))),,$(if $(strip $(PKG_SOURCE_URL)),$(call Download,default)))
+ $(if $(if $(PKG_HOST_ONLY),,$(if $(and $(filter host-%,$(MAKECMDGOALS)),$(PKG_SKIP_DOWNLOAD)),,$(STAMP_PREPARED))),,
+ $(if $(and $(CONFIG_AUTOREMOVE), $(wildcard $(HOST_STAMP_INSTALLED), $(wildcard $(HOST_STAMP_BUILT)))),,
+ $(if $(strip $(PKG_SOURCE_URL)),$(call Download,default))
+ )
+ )
endef