aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/boot/uboot-envtools/files/ath794
-rw-r--r--target/linux/ath79/dts/ar7161_ruckus_gd11.dtsi2
-rw-r--r--target/linux/ath79/dts/ar7161_ruckus_zf7341.dts8
-rw-r--r--target/linux/ath79/dts/ar7161_ruckus_zf734x.dtsi119
-rw-r--r--target/linux/ath79/dts/ar7161_ruckus_zf7363.dts39
-rw-r--r--target/linux/ath79/generic/base-files/etc/board.d/02_network4
-rw-r--r--target/linux/ath79/image/generic.mk15
7 files changed, 189 insertions, 2 deletions
diff --git a/package/boot/uboot-envtools/files/ath79 b/package/boot/uboot-envtools/files/ath79
index 3b3ff43b13..b968fa8fde 100644
--- a/package/boot/uboot-envtools/files/ath79
+++ b/package/boot/uboot-envtools/files/ath79
@@ -140,7 +140,9 @@ qihoo,c301)
ubootenv_add_uci_config "/dev/mtd9" "0x0" "0x10000" "0x10000"
;;
ruckus,zf7025|\
-ruckus,zf7351)
+ruckus,zf7341|\
+ruckus,zf7351|\
+ruckus,zf7363)
ubootenv_add_uci_config "/dev/mtd5" "0x0" "0x40000" "0x40000"
;;
ruckus,zf7321|\
diff --git a/target/linux/ath79/dts/ar7161_ruckus_gd11.dtsi b/target/linux/ath79/dts/ar7161_ruckus_gd11.dtsi
index c640765545..e97e31e58e 100644
--- a/target/linux/ath79/dts/ar7161_ruckus_gd11.dtsi
+++ b/target/linux/ath79/dts/ar7161_ruckus_gd11.dtsi
@@ -16,7 +16,7 @@
label-mac-device = &eth0;
};
- keys {
+ keys: keys {
compatible = "gpio-keys";
reset {
diff --git a/target/linux/ath79/dts/ar7161_ruckus_zf7341.dts b/target/linux/ath79/dts/ar7161_ruckus_zf7341.dts
new file mode 100644
index 0000000000..17735e596f
--- /dev/null
+++ b/target/linux/ath79/dts/ar7161_ruckus_zf7341.dts
@@ -0,0 +1,8 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "ar7161_ruckus_zf734x.dtsi"
+
+/ {
+ model = "Ruckus ZoneFlex 7341[-U]";
+ compatible = "ruckus,zf7341", "qca,ar7161";
+};
diff --git a/target/linux/ath79/dts/ar7161_ruckus_zf734x.dtsi b/target/linux/ath79/dts/ar7161_ruckus_zf734x.dtsi
new file mode 100644
index 0000000000..8861b09d1b
--- /dev/null
+++ b/target/linux/ath79/dts/ar7161_ruckus_zf734x.dtsi
@@ -0,0 +1,119 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "ar7161_ruckus_gd11.dtsi"
+
+&keys {
+ opt {
+ /* Not used by stock firmware */
+ label = "opt";
+ linux,code = <KEY_WPS_BUTTON>;
+ gpios = <&gpio 11 GPIO_ACTIVE_HIGH>;
+ debounce-interval = <60>;
+ };
+};
+
+&beamforming_2g_gpio {
+ /* Default beamforming switches configuration from stock firmware,
+ * the AP is started and for broadcast frames - all outputs high */
+ lb0 {
+ line-name = "beamforming:2g:lb0";
+ gpios = <0 GPIO_ACTIVE_LOW>;
+ output-high;
+ gpio-hog;
+ };
+
+ lb1 {
+ line-name = "beamforming:2g:lb1";
+ gpios = <1 GPIO_ACTIVE_LOW>;
+ output-high;
+ gpio-hog;
+ };
+
+ lb2 {
+ line-name = "beamforming:2g:lb2";
+ gpios = <2 GPIO_ACTIVE_LOW>;
+ output-high;
+ gpio-hog;
+ };
+
+ lb3 {
+ line-name = "beamforming:2g:lb3";
+ gpios = <3 GPIO_ACTIVE_LOW>;
+ output-high;
+ gpio-hog;
+ };
+
+ lb4 {
+ line-name = "beamforming:2g:lb4";
+ gpios = <4 GPIO_ACTIVE_LOW>;
+ output-high;
+ gpio-hog;
+ };
+
+ lb5 {
+ line-name = "beamforming:2g:lb5";
+ gpios = <5 GPIO_ACTIVE_LOW>;
+ output-high;
+ gpio-hog;
+ };
+
+ lb6 {
+ line-name = "beamforming:2g:lb6";
+ gpios = <6 GPIO_ACTIVE_LOW>;
+ output-high;
+ gpio-hog;
+ };
+
+ lb7 {
+ line-name = "beamforming:2g:lb7";
+ gpios = <7 GPIO_ACTIVE_LOW>;
+ output-high;
+ gpio-hog;
+ };
+};
+
+&beamforming_5g_gpio {
+ /* Default beamforming switches configuration from stock firmware,
+ * the AP is started and for broadcast frames - all outputs high */
+ hb0 {
+ line-name = "beamforming:5g:hb0";
+ gpios = <0 GPIO_ACTIVE_LOW>;
+ output-high;
+ gpio-hog;
+ };
+
+ hb1 {
+ line-name = "beamforming:5g:hb1";
+ gpios = <1 GPIO_ACTIVE_LOW>;
+ output-high;
+ gpio-hog;
+ };
+
+ hb2 {
+ line-name = "beamforming:5g:hb2";
+ gpios = <2 GPIO_ACTIVE_LOW>;
+ output-high;
+ gpio-hog;
+ };
+
+ hb3 {
+ line-name = "beamforming:5g:hb3";
+ gpios = <3 GPIO_ACTIVE_LOW>;
+ output-high;
+ gpio-hog;
+ };
+
+ hb4 {
+ line-name = "beamforming:5g:hb4";
+ gpios = <4 GPIO_ACTIVE_LOW>;
+ output-high;
+ gpio-hog;
+ };
+
+ hb5 {
+ line-name = "beamforming:5g:hb5";
+ gpios = <5 GPIO_ACTIVE_LOW>;
+ output-high;
+ gpio-hog;
+ };
+};
diff --git a/target/linux/ath79/dts/ar7161_ruckus_zf7363.dts b/target/linux/ath79/dts/ar7161_ruckus_zf7363.dts
new file mode 100644
index 0000000000..4ece56dd0a
--- /dev/null
+++ b/target/linux/ath79/dts/ar7161_ruckus_zf7363.dts
@@ -0,0 +1,39 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "ar7161_ruckus_zf734x.dtsi"
+
+/ {
+ model = "Ruckus ZoneFlex 7343/7363[-U]";
+ compatible = "ruckus,zf7363", "qca,ar7161";
+};
+
+&mdio0 {
+ ethernet-phy@0 {
+ reg = <0x0>;
+ max-speed = <100>;
+ };
+
+ ethernet-phy@1 {
+ reg = <0x1>;
+ max-speed = <100>;
+ };
+};
+
+&eth1 {
+ status = "okay";
+ pll-data = <0x00110000 0x00001099 0x00991099>;
+ nvmem-cells = <&macaddr_bdata_6c>;
+ nvmem-cell-names = "mac-address";
+ phy-mode = "rgmii-id";
+
+ fixed-link {
+ speed = <100>;
+ full-duplex;
+ };
+};
+
+&board_data {
+ macaddr_bdata_6c: macaddr@6c {
+ reg = <0x6c 0x6>;
+ };
+};
diff --git a/target/linux/ath79/generic/base-files/etc/board.d/02_network b/target/linux/ath79/generic/base-files/etc/board.d/02_network
index a4392e0353..31ea891d57 100644
--- a/target/linux/ath79/generic/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/generic/base-files/etc/board.d/02_network
@@ -67,6 +67,7 @@ ath79_setup_interfaces()
pisen,wmb001n|\
pisen,wmm003n|\
ruckus,zf7321|\
+ ruckus,zf7341|\
ruckus,zf7351|\
siemens,ws-ap3610|\
sophos,ap15|\
@@ -139,6 +140,7 @@ ath79_setup_interfaces()
engenius,ews511ap|\
engenius,ews660ap|\
ocedo,ursus|\
+ ruckus,zf7363|\
ruckus,zf7372|\
ubnt,unifi-ap-outdoor-plus)
ucidef_set_interface_lan "eth0 eth1"
@@ -745,7 +747,9 @@ ath79_setup_macs()
;;
ruckus,zf7025|\
ruckus,zf7321|\
+ ruckus,zf7341|\
ruckus,zf7351|\
+ ruckus,zf7363|\
ruckus,zf7372)
lan_mac=$(mtd_get_mac_binary board-data 0x807E)
label_mac=$lan_mac
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index fd63b623cd..608b51766f 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -2538,6 +2538,13 @@ define Device/ruckus_gd11_common
DEVICE_PACKAGES := kmod-usb2 kmod-usb-chipidea2
endef
+define Device/ruckus_zf7341
+ $(Device/ruckus_gd11_common)
+ DEVICE_MODEL := ZoneFlex 7341[-U]
+ DEVICE_PACKAGES += -swconfig
+endef
+TARGET_DEVICES += ruckus_zf7341
+
define Device/ruckus_zf7351
$(Device/ruckus_gd11_common)
DEVICE_MODEL := ZoneFlex 7351[-U]
@@ -2545,6 +2552,14 @@ define Device/ruckus_zf7351
endef
TARGET_DEVICES += ruckus_zf7351
+define Device/ruckus_zf7363
+ $(Device/ruckus_gd11_common)
+ DEVICE_MODEL := ZoneFlex 7363[-U]
+ DEVICE_ALT0_VENDOR := Ruckus
+ DEVICE_ALT0_MODEL := ZoneFlex 7343[-U]
+endef
+TARGET_DEVICES += ruckus_zf7363
+
define Device/ruckus_zf73xx_common
$(Device/ruckus_common)
DEVICE_PACKAGES := -swconfig kmod-usb2 kmod-usb-chipidea2