aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/network/utils/iproute2/Makefile4
-rw-r--r--package/network/utils/iproute2/patches/105-ipstats-Define-MIN-function-to-fix-undefined-referen.patch27
-rw-r--r--package/network/utils/iproute2/patches/170-ip_tiny.patch6
-rw-r--r--package/network/utils/iproute2/patches/195-build_variant_ip_tc.patch2
4 files changed, 33 insertions, 6 deletions
diff --git a/package/network/utils/iproute2/Makefile b/package/network/utils/iproute2/Makefile
index 123b0ce238..5439c050c1 100644
--- a/package/network/utils/iproute2/Makefile
+++ b/package/network/utils/iproute2/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=iproute2
-PKG_VERSION:=5.18.0
+PKG_VERSION:=5.19.0
PKG_RELEASE:=$(AUTORELEASE)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@KERNEL/linux/utils/net/iproute2
-PKG_HASH:=5ba3d464d51c8c283550d507ffac3d10f7aec587b7c66b0ccb6950643646389e
+PKG_HASH:=26b7a34d6a7fd2f7a42e2b39c5a90cb61bac522d1096067ffeb195e5693d7791
PKG_BUILD_PARALLEL:=1
PKG_BUILD_DEPENDS:=iptables
PKG_LICENSE:=GPL-2.0
diff --git a/package/network/utils/iproute2/patches/105-ipstats-Define-MIN-function-to-fix-undefined-referen.patch b/package/network/utils/iproute2/patches/105-ipstats-Define-MIN-function-to-fix-undefined-referen.patch
new file mode 100644
index 0000000000..7bf55dd57b
--- /dev/null
+++ b/package/network/utils/iproute2/patches/105-ipstats-Define-MIN-function-to-fix-undefined-referen.patch
@@ -0,0 +1,27 @@
+From c69e8e474936795a2cd7638b11ce3e99ff4d5ae7 Mon Sep 17 00:00:00 2001
+From: Nick Hainke <vincent@systemli.org>
+Date: Sat, 6 Aug 2022 10:00:20 +0200
+Subject: [PATCH] ipstats: Define MIN function to fix undefined references
+
+Fixes errors in the form of:
+ in function `ipstats_show_64':
+ <artificial>:(.text+0x4e30): undefined reference to `MIN'
+
+Signed-off-by: Nick Hainke <vincent@systemli.org>
+---
+ ip/ipstats.c | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+--- a/ip/ipstats.c
++++ b/ip/ipstats.c
+@@ -6,6 +6,10 @@
+ #include "utils.h"
+ #include "ip_common.h"
+
++#ifndef MIN
++#define MIN(a, b) ((a) < (b) ? (a) : (b))
++#endif
++
+ struct ipstats_stat_dump_filters {
+ /* mask[0] filters outer attributes. Then individual nests have their
+ * filtering mask at the index of the nested attribute.
diff --git a/package/network/utils/iproute2/patches/170-ip_tiny.patch b/package/network/utils/iproute2/patches/170-ip_tiny.patch
index 399dd4fc87..1196be31f0 100644
--- a/package/network/utils/iproute2/patches/170-ip_tiny.patch
+++ b/package/network/utils/iproute2/patches/170-ip_tiny.patch
@@ -1,6 +1,6 @@
--- a/ip/Makefile
+++ b/ip/Makefile
-@@ -18,6 +18,13 @@ RTMONOBJ=rtmon.o
+@@ -19,6 +19,13 @@ RTMONOBJ=rtmon.o
include ../config.mk
@@ -14,7 +14,7 @@
ALLOBJ=$(IPOBJ) $(RTMONOBJ)
SCRIPTS=routel
TARGETS=ip rtmon
-@@ -47,7 +54,7 @@ else
+@@ -48,7 +55,7 @@ else
ip: static-syms.o
static-syms.o: static-syms.h
@@ -93,8 +93,8 @@
{ "ioam", do_ioam6 },
+#endif
{ "help", do_help },
+ { "stats", do_ipstats },
{ 0 }
- };
--- a/lib/Makefile
+++ b/lib/Makefile
@@ -3,6 +3,10 @@ include ../config.mk
diff --git a/package/network/utils/iproute2/patches/195-build_variant_ip_tc.patch b/package/network/utils/iproute2/patches/195-build_variant_ip_tc.patch
index a219251573..dc9c0b2969 100644
--- a/package/network/utils/iproute2/patches/195-build_variant_ip_tc.patch
+++ b/package/network/utils/iproute2/patches/195-build_variant_ip_tc.patch
@@ -1,6 +1,6 @@
--- a/ip/Makefile
+++ b/ip/Makefile
-@@ -27,7 +27,7 @@ STATIC_SYM_SOURCES:=$(filter-out $(STATI
+@@ -28,7 +28,7 @@ STATIC_SYM_SOURCES:=$(filter-out $(STATI
ALLOBJ=$(IPOBJ) $(RTMONOBJ)
SCRIPTS=routel