aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--tools/libressl/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/tools/libressl/Makefile b/tools/libressl/Makefile
index 236a7c2c30..aecc788972 100644
--- a/tools/libressl/Makefile
+++ b/tools/libressl/Makefile
@@ -24,9 +24,15 @@ HOST_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/host-build.mk
HOSTCC := $(HOSTCC_NOCACHE)
-HOST_CONFIGURE_ARGS += --enable-static --disable-shared --disable-tests
+
HOST_CFLAGS += $(HOST_FPIC)
+HOST_CONFIGURE_ARGS += \
+ --enable-static \
+ --disable-shared \
+ --with-pic \
+ --disable-tests
+
ifeq ($(GNU_HOST_NAME),x86_64-linux-gnux32)
HOST_CONFIGURE_ARGS += --disable-asm
endif