aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/linux/ath79/patches-5.10/0003-leds-add-reset-controller-based-driver.patch10
-rw-r--r--target/linux/ath79/patches-5.15/0003-leds-add-reset-controller-based-driver.patch10
-rw-r--r--target/linux/generic/hack-5.10/800-ubnt-ledbar-driver.patch6
-rw-r--r--target/linux/generic/pending-5.15/020-05-mm-multigenerational-lru-aging.patch2
-rw-r--r--target/linux/generic/pending-5.15/120-Fix-alloc_node_mem_map-with-ARCH_PFN_OFFSET-calcu.patch2
5 files changed, 15 insertions, 15 deletions
diff --git a/target/linux/ath79/patches-5.10/0003-leds-add-reset-controller-based-driver.patch b/target/linux/ath79/patches-5.10/0003-leds-add-reset-controller-based-driver.patch
index 4a721f2af2..7505f682ab 100644
--- a/target/linux/ath79/patches-5.10/0003-leds-add-reset-controller-based-driver.patch
+++ b/target/linux/ath79/patches-5.10/0003-leds-add-reset-controller-based-driver.patch
@@ -13,9 +13,9 @@ Signed-off-by: John Crispin <john@phrozen.org>
--- a/drivers/leds/Kconfig
+++ b/drivers/leds/Kconfig
-@@ -931,6 +931,17 @@ config LEDS_ACER_A500
-
- source "drivers/leds/blink/Kconfig"
+@@ -941,6 +941,17 @@ config LEDS_UBNT_LEDBAR
+ To compile this driver as a module, choose M here: the module
+ will be called leds-ubnt-ledbar.
+config LEDS_RESET
+ tristate "LED support for reset-controller API"
@@ -176,10 +176,10 @@ Signed-off-by: John Crispin <john@phrozen.org>
+MODULE_ALIAS("platform:leds-reset");
--- a/drivers/leds/Makefile
+++ b/drivers/leds/Makefile
-@@ -93,6 +93,7 @@ obj-$(CONFIG_LEDS_TURRIS_OMNIA) += leds
- obj-$(CONFIG_LEDS_WM831X_STATUS) += leds-wm831x-status.o
+@@ -94,6 +94,7 @@ obj-$(CONFIG_LEDS_WM831X_STATUS) += leds
obj-$(CONFIG_LEDS_WM8350) += leds-wm8350.o
obj-$(CONFIG_LEDS_WRAP) += leds-wrap.o
+ obj-$(CONFIG_LEDS_UBNT_LEDBAR) += leds-ubnt-ledbar.o
+obj-$(CONFIG_LEDS_RESET) += leds-reset.o
# LED SPI Drivers
diff --git a/target/linux/ath79/patches-5.15/0003-leds-add-reset-controller-based-driver.patch b/target/linux/ath79/patches-5.15/0003-leds-add-reset-controller-based-driver.patch
index 7122756c52..f958e79608 100644
--- a/target/linux/ath79/patches-5.15/0003-leds-add-reset-controller-based-driver.patch
+++ b/target/linux/ath79/patches-5.15/0003-leds-add-reset-controller-based-driver.patch
@@ -13,9 +13,9 @@ Signed-off-by: John Crispin <john@phrozen.org>
--- a/drivers/leds/Kconfig
+++ b/drivers/leds/Kconfig
-@@ -876,6 +876,17 @@ source "drivers/leds/blink/Kconfig"
- comment "Flash and Torch LED drivers"
- source "drivers/leds/flash/Kconfig"
+@@ -886,6 +886,17 @@ config LEDS_UBNT_LEDBAR
+ To compile this driver as a module, choose M here: the module
+ will be called leds-ubnt-ledbar.
+config LEDS_RESET
+ tristate "LED support for reset-controller API"
@@ -176,10 +176,10 @@ Signed-off-by: John Crispin <john@phrozen.org>
+MODULE_ALIAS("platform:leds-reset");
--- a/drivers/leds/Makefile
+++ b/drivers/leds/Makefile
-@@ -87,6 +87,7 @@ obj-$(CONFIG_LEDS_TURRIS_OMNIA) += leds
- obj-$(CONFIG_LEDS_WM831X_STATUS) += leds-wm831x-status.o
+@@ -88,6 +88,7 @@ obj-$(CONFIG_LEDS_WM831X_STATUS) += leds
obj-$(CONFIG_LEDS_WM8350) += leds-wm8350.o
obj-$(CONFIG_LEDS_WRAP) += leds-wrap.o
+ obj-$(CONFIG_LEDS_UBNT_LEDBAR) += leds-ubnt-ledbar.o
+obj-$(CONFIG_LEDS_RESET) += leds-reset.o
# LED SPI Drivers
diff --git a/target/linux/generic/hack-5.10/800-ubnt-ledbar-driver.patch b/target/linux/generic/hack-5.10/800-ubnt-ledbar-driver.patch
index 92264eedf9..2b4baab456 100644
--- a/target/linux/generic/hack-5.10/800-ubnt-ledbar-driver.patch
+++ b/target/linux/generic/hack-5.10/800-ubnt-ledbar-driver.patch
@@ -1,8 +1,8 @@
--- a/drivers/leds/Kconfig
+++ b/drivers/leds/Kconfig
-@@ -929,6 +929,16 @@ config LEDS_ACER_A500
- This option enables support for the Power Button LED of
- Acer Iconia Tab A500.
+@@ -931,6 +931,16 @@ config LEDS_ACER_A500
+
+ source "drivers/leds/blink/Kconfig"
+config LEDS_UBNT_LEDBAR
+ tristate "LED support for Ubiquiti UniFi 6 LR"
diff --git a/target/linux/generic/pending-5.15/020-05-mm-multigenerational-lru-aging.patch b/target/linux/generic/pending-5.15/020-05-mm-multigenerational-lru-aging.patch
index e5622ccbbe..6fc93d9422 100644
--- a/target/linux/generic/pending-5.15/020-05-mm-multigenerational-lru-aging.patch
+++ b/target/linux/generic/pending-5.15/020-05-mm-multigenerational-lru-aging.patch
@@ -168,7 +168,7 @@ Change-Id: I3ae8abc3100d023cecb3a699d86020ae6fc10a45
#include <asm/tlbflush.h>
-@@ -790,6 +791,13 @@ static bool page_referenced_one(struct p
+@@ -793,6 +794,13 @@ static bool page_referenced_one(struct p
}
if (pvmw.pte) {
diff --git a/target/linux/generic/pending-5.15/120-Fix-alloc_node_mem_map-with-ARCH_PFN_OFFSET-calcu.patch b/target/linux/generic/pending-5.15/120-Fix-alloc_node_mem_map-with-ARCH_PFN_OFFSET-calcu.patch
index 4e347a4671..b0b399a2dd 100644
--- a/target/linux/generic/pending-5.15/120-Fix-alloc_node_mem_map-with-ARCH_PFN_OFFSET-calcu.patch
+++ b/target/linux/generic/pending-5.15/120-Fix-alloc_node_mem_map-with-ARCH_PFN_OFFSET-calcu.patch
@@ -71,7 +71,7 @@ Signed-off-by: Tobias Wolf <dev-NTEO@vplace.de>
--- a/mm/page_alloc.c
+++ b/mm/page_alloc.c
-@@ -7556,7 +7556,7 @@ static void __init alloc_node_mem_map(st
+@@ -7557,7 +7557,7 @@ static void __init alloc_node_mem_map(st
if (pgdat == NODE_DATA(0)) {
mem_map = NODE_DATA(0)->node_mem_map;
if (page_to_pfn(mem_map) != pgdat->node_start_pfn)