aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/linux/ramips/dts/mt7620a_netcore_nw5212.dts132
-rw-r--r--target/linux/ramips/image/mt7620.mk10
-rw-r--r--target/linux/ramips/mt7620/base-files/etc/board.d/01_leds15
-rw-r--r--target/linux/ramips/mt7620/base-files/etc/board.d/02_network1
4 files changed, 151 insertions, 7 deletions
diff --git a/target/linux/ramips/dts/mt7620a_netcore_nw5212.dts b/target/linux/ramips/dts/mt7620a_netcore_nw5212.dts
new file mode 100644
index 0000000000..25287ebc0b
--- /dev/null
+++ b/target/linux/ramips/dts/mt7620a_netcore_nw5212.dts
@@ -0,0 +1,132 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "mt7620a.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+ compatible = "netcore,nw5212", "ralink,mt7620a-soc";
+ model = "Netcore NW5212";
+
+ aliases {
+ label-mac-device = &ethernet;
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ lan4 {
+ label = "green:lan4";
+ gpios = <&gpio2 0 GPIO_ACTIVE_LOW>;
+ };
+
+ lan3 {
+ label = "green:lan3";
+ gpios = <&gpio2 1 GPIO_ACTIVE_LOW>;
+ };
+
+ lan2 {
+ label = "green:lan2";
+ gpios = <&gpio2 2 GPIO_ACTIVE_LOW>;
+ };
+
+ lan1 {
+ label = "green:lan1";
+ gpios = <&gpio2 3 GPIO_ACTIVE_LOW>;
+ };
+
+ wan {
+ label = "green:wan";
+ gpios = <&gpio2 4 GPIO_ACTIVE_LOW>;
+ };
+
+ wlan2g {
+ label = "green:wlan2g";
+ gpios = <&gpio3 0 GPIO_ACTIVE_LOW>;
+ linux,default-trigger = "phy0tpt";
+ };
+ };
+
+ keys {
+ compatible = "gpio-keys";
+
+ reset {
+ label = "reset";
+ gpios = <&gpio0 13 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_RESTART>;
+ };
+ };
+};
+
+&gpio2 {
+ status = "okay";
+};
+
+&gpio3 {
+ status = "okay";
+};
+
+&spi0 {
+ status = "okay";
+
+ flash@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <70000000>;
+ m25p,fast-read;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x30000>;
+ read-only;
+ };
+
+ partition@30000 {
+ label = "u-boot-env";
+ reg = <0x30000 0x10000>;
+ };
+
+ factory: partition@40000 {
+ label = "factory";
+ reg = <0x40000 0x10000>;
+ read-only;
+ };
+
+ partition@50000 {
+ compatible = "denx,uimage";
+ label = "firmware";
+ reg = <0x50000 0xfb0000>;
+ };
+ };
+ };
+};
+
+&state_default {
+ gpio {
+ groups = "uartf", "wled", "ephy";
+ function = "gpio";
+ };
+};
+
+&ethernet {
+ mtd-mac-address = <&factory 0x28>;
+ mediatek,portmap = "llllw";
+};
+
+&ehci {
+ status = "okay";
+};
+
+&ohci {
+ status = "okay";
+};
+
+&wmac {
+ ralink,mtd-eeprom = <&factory 0x0>;
+};
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index b3551fa6cb..f6ad162779 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -729,6 +729,16 @@ define Device/microduino_microwrt
endef
TARGET_DEVICES += microduino_microwrt
+define Device/netcore_nw5212
+ SOC := mt7620a
+ IMAGE_SIZE := 16064k
+ BLOCKSIZE := 4k
+ DEVICE_VENDOR := Netcore
+ DEVICE_MODEL := NW5212
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci
+endef
+TARGET_DEVICES += netcore_nw5212
+
define Device/netgear_ex2700
SOC := mt7620a
NETGEAR_HW_ID := 29764623+4+0+32+2x2+0
diff --git a/target/linux/ramips/mt7620/base-files/etc/board.d/01_leds b/target/linux/ramips/mt7620/base-files/etc/board.d/01_leds
index 889818c631..b1dc36672d 100644
--- a/target/linux/ramips/mt7620/base-files/etc/board.d/01_leds
+++ b/target/linux/ramips/mt7620/base-files/etc/board.d/01_leds
@@ -160,6 +160,14 @@ lenovo,newifi-y1s)
ucidef_set_led_netdev "wifi5g" "WIFI5G" "blue:wifi" "wlan0"
ucidef_set_led_netdev "wan" "WAN" "blue:internet" "eth0.2" "tx rx"
;;
+netcore,nw5212|\
+netgear,jwnr2010-v5)
+ ucidef_set_led_switch "lan1" "lan1" "green:lan1" "switch0" "0x08"
+ ucidef_set_led_switch "lan2" "lan2" "green:lan2" "switch0" "0x04"
+ ucidef_set_led_switch "lan3" "lan3" "green:lan3" "switch0" "0x02"
+ ucidef_set_led_switch "lan4" "lan4" "green:lan4" "switch0" "0x01"
+ ucidef_set_led_switch "wan" "wan" "green:wan" "switch0" "0x10"
+ ;;
netgear,ex2700|\
netgear,wn3000rp-v3|\
netgear,wn3100rp-v2)
@@ -170,13 +178,6 @@ netgear,ex6130)
ucidef_set_led_netdev "wlan5g" "ROUTER (green)" "green:router" "wlan0"
ucidef_set_led_netdev "wlan2g" "DEVICE (green)" "green:device" "wlan1"
;;
-netgear,jwnr2010-v5)
- ucidef_set_led_switch "lan1" "lan1" "green:lan1" "switch0" "0x08"
- ucidef_set_led_switch "lan2" "lan2" "green:lan2" "switch0" "0x04"
- ucidef_set_led_switch "lan3" "lan3" "green:lan3" "switch0" "0x02"
- ucidef_set_led_switch "lan4" "lan4" "green:lan4" "switch0" "0x01"
- ucidef_set_led_switch "wan" "wan" "green:wan" "switch0" "0x10"
- ;;
netgear,pr2000)
ucidef_set_led_switch "internet" "internet" "green:internet" "switch0" "0x01"
;;
diff --git a/target/linux/ramips/mt7620/base-files/etc/board.d/02_network b/target/linux/ramips/mt7620/base-files/etc/board.d/02_network
index 7b1766766b..79df102056 100644
--- a/target/linux/ramips/mt7620/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/mt7620/base-files/etc/board.d/02_network
@@ -111,6 +111,7 @@ ramips_setup_interfaces()
"0:lan" "6@eth0"
;;
dlink,dir-810l|\
+ netcore,nw5212|\
netgear,jwnr2010-v5|\
phicomm,k2-v22.4|\
phicomm,k2-v22.5|\