aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/image-commands.mk10
-rw-r--r--target/linux/ath79/image/Makefile3
-rwxr-xr-xtarget/linux/ath79/image/empty-squashfs-lzmabin0 -> 150 bytes
3 files changed, 3 insertions, 10 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 0c13f30fef..e1951672e6 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -103,16 +103,6 @@ define Build/append-rootfs
dd if=$(IMAGE_ROOTFS) >> $@
endef
-define Build/append-squashfs-fakeroot-be
- rm -rf $@.fakefs $@.fakesquashfs
- mkdir $@.fakefs
- $(STAGING_DIR_HOST)/bin/mksquashfs3-lzma \
- $@.fakefs $@.fakesquashfs \
- -noappend -root-owned -be -nopad -b 65536 \
- $(if $(SOURCE_DATE_EPOCH),-fixed-time $(SOURCE_DATE_EPOCH))
- cat $@.fakesquashfs >> $@
-endef
-
define Build/append-squashfs4-fakeroot
rm -rf $@.fakefs $@.fakesquashfs
mkdir $@.fakefs
diff --git a/target/linux/ath79/image/Makefile b/target/linux/ath79/image/Makefile
index 8328be7667..02fd26bfd8 100644
--- a/target/linux/ath79/image/Makefile
+++ b/target/linux/ath79/image/Makefile
@@ -60,6 +60,9 @@ define Build/relocate-kernel
rm -rf $@.relocate
endef
+define Build/append-squashfs-fakeroot-be
+ cat ./empty-squashfs-lzma >> $@
+endef
define Device/Default
DEVICE_DTS_DIR := ../dts
diff --git a/target/linux/ath79/image/empty-squashfs-lzma b/target/linux/ath79/image/empty-squashfs-lzma
new file mode 100755
index 0000000000..803a7661a7
--- /dev/null
+++ b/target/linux/ath79/image/empty-squashfs-lzma
Binary files differ