aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/image-commands.mk10
-rw-r--r--target/linux/ath79/image/Makefile3
-rwxr-xr-xtarget/linux/ath79/image/empty-squashfs-lzmabin150 -> 0 bytes
3 files changed, 10 insertions, 3 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index e1951672e6..0c13f30fef 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -103,6 +103,16 @@ define Build/append-rootfs
dd if=$(IMAGE_ROOTFS) >> $@
endef
+define Build/append-squashfs-fakeroot-be
+ rm -rf $@.fakefs $@.fakesquashfs
+ mkdir $@.fakefs
+ $(STAGING_DIR_HOST)/bin/mksquashfs3-lzma \
+ $@.fakefs $@.fakesquashfs \
+ -noappend -root-owned -be -nopad -b 65536 \
+ $(if $(SOURCE_DATE_EPOCH),-fixed-time $(SOURCE_DATE_EPOCH))
+ cat $@.fakesquashfs >> $@
+endef
+
define Build/append-squashfs4-fakeroot
rm -rf $@.fakefs $@.fakesquashfs
mkdir $@.fakefs
diff --git a/target/linux/ath79/image/Makefile b/target/linux/ath79/image/Makefile
index 02fd26bfd8..8328be7667 100644
--- a/target/linux/ath79/image/Makefile
+++ b/target/linux/ath79/image/Makefile
@@ -60,9 +60,6 @@ define Build/relocate-kernel
rm -rf $@.relocate
endef
-define Build/append-squashfs-fakeroot-be
- cat ./empty-squashfs-lzma >> $@
-endef
define Device/Default
DEVICE_DTS_DIR := ../dts
diff --git a/target/linux/ath79/image/empty-squashfs-lzma b/target/linux/ath79/image/empty-squashfs-lzma
deleted file mode 100755
index 803a7661a7..0000000000
--- a/target/linux/ath79/image/empty-squashfs-lzma
+++ /dev/null
Binary files differ