aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--config/Config-kernel.in10
-rw-r--r--package/kernel/linux/modules/netsupport.mk17
2 files changed, 27 insertions, 0 deletions
diff --git a/config/Config-kernel.in b/config/Config-kernel.in
index 98dab9b6fd..31d4e276fd 100644
--- a/config/Config-kernel.in
+++ b/config/Config-kernel.in
@@ -1043,6 +1043,16 @@ if KERNEL_IPV6
endif
#
+# Miscellaneous network configuration
+#
+
+config KERNEL_NET_L3_MASTER_DEV
+ bool "L3 Master device support"
+ help
+ This module provides glue between core networking code and device
+ drivers to support L3 master devices like VRF.
+
+#
# NFS related symbols
#
config KERNEL_IP_PNP
diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index 166172dbf3..e37ab59575 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -564,6 +564,23 @@ endef
$(eval $(call KernelPackage,veth))
+define KernelPackage/vrf
+ SUBMENU:=$(NETWORK_SUPPORT_MENU)
+ TITLE:=Virtual Routing and Forwarding (Lite)
+ DEPENDS:=@KERNEL_NET_L3_MASTER_DEV
+ KCONFIG:=CONFIG_NET_VRF
+ FILES:=$(LINUX_DIR)/drivers/net/vrf.ko
+ AUTOLOAD:=$(call AutoLoad,30,vrf)
+endef
+
+define KernelPackage/vrf/description
+ This option enables the support for mapping interfaces into VRF's. The
+ support enables VRF devices.
+endef
+
+$(eval $(call KernelPackage,vrf))
+
+
define KernelPackage/slhc
SUBMENU:=$(NETWORK_SUPPORT_MENU)
HIDDEN:=1