aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/image-commands.mk8
1 files changed, 5 insertions, 3 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 97176f7d7b..913e1c2411 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -524,12 +524,14 @@ define Build/xor-image
endef
define Build/zip
+ rm -rf $@.tmp
mkdir $@.tmp
- mv $@ $@.tmp/$(1)
+ mv $@ $@.tmp/$(word 1,$(1))
- zip -j -X \
+ $(STAGING_DIR_HOST)/bin/zip -j -X \
$(if $(SOURCE_DATE_EPOCH),--mtime="$(SOURCE_DATE_EPOCH)") \
- $@ $@.tmp/$(if $(1),$(1),$@)
+ $(wordlist 2,$(words $(1)),$(1)) \
+ $@ $@.tmp/$(if $(word 1,$(1)),$(word 1,$(1)),$$(basename $@))
rm -rf $@.tmp
endef