aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/linux/bcm53xx/base-files/etc/board.d/02_network3
-rw-r--r--target/linux/bcm53xx/image/Makefile9
2 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/bcm53xx/base-files/etc/board.d/02_network b/target/linux/bcm53xx/base-files/etc/board.d/02_network
index 6d970e1d0e..822320c0a6 100644
--- a/target/linux/bcm53xx/base-files/etc/board.d/02_network
+++ b/target/linux/bcm53xx/base-files/etc/board.d/02_network
@@ -13,6 +13,9 @@ bcm53xx_setup_interfaces()
asus,rt-ac87u)
ucidef_set_interfaces_lan_wan "lan1 lan2 lan3" "wan"
;;
+ asus,rt-ac88u)
+ ucidef_set_interfaces_lan_wan "lan1 lan2 lan3 lan4 extsw" "wan"
+ ;;
linksys,panamera)
ucidef_set_interfaces_lan_wan "lan1 lan2 lan3 lan4 lan5 lan6 lan7 lan8 extsw" "wan"
;;
diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index aadac9c3d4..3df24013ce 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -167,6 +167,15 @@ define Device/asus_rt-ac87u
endef
TARGET_DEVICES += asus_rt-ac87u
+define Device/asus_rt-ac88u
+ $(call Device/asus)
+ DEVICE_MODEL := RT-AC88U
+ DEVICE_PACKAGES := $(BRCMFMAC_4366C0) $(USB3_PACKAGES)
+ ASUS_PRODUCTID := RT-AC88U
+ BROKEN := y
+endef
+TARGET_DEVICES += asus_rt-ac88u
+
define Device/asus_rt-n18u
$(call Device/asus)
DEVICE_MODEL := RT-N18U