aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/image-commands.mk3
1 files changed, 1 insertions, 2 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 939f5ef2db..21f851d205 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -541,8 +541,7 @@ define Build/zip
rm -rf $@.tmp
mkdir $@.tmp
mv $@ $@.tmp/$(word 1,$(1))
-
- $(STAGING_DIR_HOST)/bin/zip -j -X \
+ TZ=UTC $(STAGING_DIR_HOST)/bin/zip -j -X \
$(if $(SOURCE_DATE_EPOCH),--mtime="$(SOURCE_DATE_EPOCH)") \
$(wordlist 2,$(words $(1)),$(1)) \
$@ $@.tmp/$(if $(word 1,$(1)),$(word 1,$(1)),$$(basename $@))