aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/boot/uboot-envtools/files/mvebu3
-rwxr-xr-xtarget/linux/mvebu/cortexa72/base-files/etc/board.d/02_network3
-rwxr-xr-xtarget/linux/mvebu/cortexa72/base-files/lib/upgrade/platform.sh9
-rw-r--r--target/linux/mvebu/image/cortexa72.mk20
4 files changed, 28 insertions, 7 deletions
diff --git a/package/boot/uboot-envtools/files/mvebu b/package/boot/uboot-envtools/files/mvebu
index 590000aae7..8ed1f87ead 100644
--- a/package/boot/uboot-envtools/files/mvebu
+++ b/package/boot/uboot-envtools/files/mvebu
@@ -24,7 +24,8 @@ globalscale,espressobin|\
globalscale,espressobin-emmc|\
globalscale,espressobin-v7|\
globalscale,espressobin-v7-emmc|\
-marvell,armada8040-mcbin-doubleshot)
+marvell,armada8040-mcbin-doubleshot|\
+marvell,armada8040-mcbin-singleshot)
ubootenv_add_uci_config "/dev/mtd0" "0x3f0000" "0x10000" "0x10000" "1"
;;
linksys,wrt1200ac|\
diff --git a/target/linux/mvebu/cortexa72/base-files/etc/board.d/02_network b/target/linux/mvebu/cortexa72/base-files/etc/board.d/02_network
index 32053d74e8..9ab3c8174d 100755
--- a/target/linux/mvebu/cortexa72/base-files/etc/board.d/02_network
+++ b/target/linux/mvebu/cortexa72/base-files/etc/board.d/02_network
@@ -11,7 +11,8 @@ board_config_update
board=$(board_name)
case "$board" in
-marvell,armada8040-mcbin-doubleshot)
+marvell,armada8040-mcbin-doubleshot|\
+marvell,armada8040-mcbin-singleshot)
ucidef_set_interfaces_lan_wan "eth0 eth1 eth3" "eth2"
;;
marvell,armada8040-db)
diff --git a/target/linux/mvebu/cortexa72/base-files/lib/upgrade/platform.sh b/target/linux/mvebu/cortexa72/base-files/lib/upgrade/platform.sh
index 75d2933f05..04ea634097 100755
--- a/target/linux/mvebu/cortexa72/base-files/lib/upgrade/platform.sh
+++ b/target/linux/mvebu/cortexa72/base-files/lib/upgrade/platform.sh
@@ -9,7 +9,8 @@ REQUIRE_IMAGE_METADATA=1
platform_check_image() {
case "$(board_name)" in
- marvell,armada8040-mcbin-doubleshot)
+ marvell,armada8040-mcbin-doubleshot|\
+ marvell,armada8040-mcbin-singleshot)
platform_check_image_sdcard "$1"
;;
*)
@@ -20,7 +21,8 @@ platform_check_image() {
platform_do_upgrade() {
case "$(board_name)" in
- marvell,armada8040-mcbin-doubleshot)
+ marvell,armada8040-mcbin-doubleshot|\
+ marvell,armada8040-mcbin-singleshot)
platform_do_upgrade_sdcard "$1"
;;
*)
@@ -30,7 +32,8 @@ platform_do_upgrade() {
}
platform_copy_config() {
case "$(board_name)" in
- marvell,armada8040-mcbin-doubleshot)
+ marvell,armada8040-mcbin-doubleshot|\
+ marvell,armada8040-mcbin-singleshot)
platform_copy_config_sdcard
;;
esac
diff --git a/target/linux/mvebu/image/cortexa72.mk b/target/linux/mvebu/image/cortexa72.mk
index 6e52109237..1440c07a0b 100644
--- a/target/linux/mvebu/image/cortexa72.mk
+++ b/target/linux/mvebu/image/cortexa72.mk
@@ -16,14 +16,30 @@ define Device/marvell_armada8040-db
endef
TARGET_DEVICES += marvell_armada8040-db
-define Device/marvell_macchiatobin
+define Device/marvell_macchiatobin-doubleshot
$(call Device/Default-arm64)
DEVICE_VENDOR := SolidRun
DEVICE_MODEL := MACCHIATObin
+ DEVICE_VARIANT := Double Shot
DEVICE_ALT0_VENDOR := SolidRun
DEVICE_ALT0_MODEL := Armada 8040 Community Board
+ DEVICE_ALT0_VARIANT := Double Shot
DEVICE_PACKAGES += kmod-i2c-mux-pca954x
DEVICE_DTS := armada-8040-mcbin
SUPPORTED_DEVICES := marvell,armada8040-mcbin-doubleshot marvell,armada8040-mcbin
endef
-TARGET_DEVICES += marvell_macchiatobin
+TARGET_DEVICES += marvell_macchiatobin-doubleshot
+
+define Device/marvell_macchiatobin-singleshot
+ $(call Device/Default-arm64)
+ DEVICE_VENDOR := SolidRun
+ DEVICE_MODEL := MACCHIATObin
+ DEVICE_VARIANT := Single Shot
+ DEVICE_ALT0_VENDOR := SolidRun
+ DEVICE_ALT0_MODEL := Armada 8040 Community Board
+ DEVICE_ALT0_VARIANT := Single Shot
+ DEVICE_PACKAGES += kmod-i2c-mux-pca954x
+ DEVICE_DTS := armada-8040-mcbin-singleshot
+ SUPPORTED_DEVICES := marvell,armada8040-mcbin-singleshot
+endef
+TARGET_DEVICES += marvell_macchiatobin-singleshot