aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--config/Config-devel.in4
-rw-r--r--include/kernel.mk2
2 files changed, 5 insertions, 1 deletions
diff --git a/config/Config-devel.in b/config/Config-devel.in
index 126462bfc3..a068f694e5 100644
--- a/config/Config-devel.in
+++ b/config/Config-devel.in
@@ -74,6 +74,10 @@ menuconfig DEVEL
Store ccache in this directory.
If not set, uses './.ccache'
+ config KERNEL_CFLAGS
+ string "Kernel extra CFLAGS" if DEVEL
+ default ""
+
config EXTERNAL_KERNEL_TREE
string "Use external kernel tree" if DEVEL
default ""
diff --git a/include/kernel.mk b/include/kernel.mk
index 5057d8bf6f..070d1bca75 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -101,7 +101,7 @@ endif
KERNEL_MAKE = $(MAKE) $(KERNEL_MAKEOPTS)
KERNEL_MAKE_FLAGS = \
- KCFLAGS="$(call iremap,$(BUILD_DIR),$(notdir $(BUILD_DIR))) $(filter-out -fno-plt,$(call qstrip,$(CONFIG_EXTRA_OPTIMIZATION)))" \
+ KCFLAGS="$(call iremap,$(BUILD_DIR),$(notdir $(BUILD_DIR))) $(filter-out -fno-plt,$(call qstrip,$(CONFIG_EXTRA_OPTIMIZATION))) $(call qstrip,$(CONFIG_KERNEL_CFLAGS))" \
HOSTCFLAGS="$(HOST_CFLAGS) -Wall -Wmissing-prototypes -Wstrict-prototypes" \
CROSS_COMPILE="$(KERNEL_CROSS)" \
ARCH="$(LINUX_KARCH)" \