aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/boot/uboot-envtools/files/mediatek_mt76234
-rw-r--r--target/linux/mediatek/image/mt7623.mk10
2 files changed, 9 insertions, 5 deletions
diff --git a/package/boot/uboot-envtools/files/mediatek_mt7623 b/package/boot/uboot-envtools/files/mediatek_mt7623
index 863c8bc211..fd2a01006a 100644
--- a/package/boot/uboot-envtools/files/mediatek_mt7623
+++ b/package/boot/uboot-envtools/files/mediatek_mt7623
@@ -17,6 +17,10 @@ bananapi,bpi-r2)
export_bootdevice
export_partdevice ubootpart 1
ubootenv_add_uci_config "/dev/$ubootpart" "0xb0000" "0x10000" "0x10000" "1"
+ ;;
+unielec,u7623-02)
+ ubootenv_add_uci_config "/dev/mmcblk0p1" "0xc0000" "0x10000" "0x10000" "1"
+ ;;
esac
config_load ubootenv
diff --git a/target/linux/mediatek/image/mt7623.mk b/target/linux/mediatek/image/mt7623.mk
index cad3dd2b93..89c771e5a0 100644
--- a/target/linux/mediatek/image/mt7623.mk
+++ b/target/linux/mediatek/image/mt7623.mk
@@ -172,11 +172,11 @@ define Device/unielec_u7623-02-emmc-512m-legacy
DEVICE_PACKAGES := kmod-fs-vfat kmod-nls-cp437 kmod-nls-iso8859-1 kmod-mmc \
mkf2fs e2fsprogs kmod-usb-ohci kmod-usb2 kmod-usb3 kmod-ata-ahci-mtk \
partx-utils
- IMAGES := sysupgrade-emmc.bin.gz
- IMAGE/sysupgrade-emmc.bin.gz := append-kernel |\
- pad-to 4864k | fat-recovery-fs |\
- pad-to 7936k | append-rootfs |\
- gzip | append-metadata
+ IMAGES := sysupgrade.bin.gz
+ IMAGE/sysupgrade.bin.gz := append-kernel |\
+ pad-to 4864k | fat-recovery-fs |\
+ pad-to 7936k | append-rootfs |\
+ gzip | append-metadata
SUPPORTED_DEVICES := unielec,u7623-02-emmc-512m
endef
TARGET_DEVICES += unielec_u7623-02-emmc-512m-legacy