aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/target.mk35
1 files changed, 32 insertions, 3 deletions
diff --git a/include/target.mk b/include/target.mk
index b0c563a0ef..03550c6ca6 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -13,13 +13,42 @@ __target_inc=1
DEVICE_TYPE?=router
# Default packages - the really basic set
-DEFAULT_PACKAGES:=base-files busybox ca-bundle dropbear fstools libc libgcc logd libustream-wolfssl mtd netifd opkg uci uclient-fetch urandom-seed urngd
+DEFAULT_PACKAGES:=\
+ base-files \
+ busybox \
+ ca-bundle \
+ dropbear \
+ fstools \
+ libc \
+ libgcc \
+ libustream-wolfssl \
+ logd \
+ mtd \
+ netifd \
+ opkg \
+ uci \
+ uclient-fetch \
+ urandom-seed \
+ urngd
# For the basic set
DEFAULT_PACKAGES.basic:=
# For nas targets
-DEFAULT_PACKAGES.nas:=block-mount fdisk lsblk mdadm
+DEFAULT_PACKAGES.nas:=\
+ block-mount \
+ fdisk \
+ lsblk \
+ mdadm
# For router targets
-DEFAULT_PACKAGES.router:=dnsmasq iptables ip6tables ppp ppp-mod-pppoe firewall odhcpd-ipv6only odhcp6c kmod-ipt-offload
+DEFAULT_PACKAGES.router:=\
+ dnsmasq \
+ firewall \
+ ip6tables \
+ iptables \
+ kmod-ipt-offload \
+ odhcp6c \
+ odhcpd-ipv6only \
+ ppp \
+ ppp-mod-pppoe
ifneq ($(DUMP),)
all: dumpinfo