aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/prereq-build.mk12
1 files changed, 6 insertions, 6 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 4c59910056..d73f0040c3 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -144,15 +144,15 @@ $(eval $(call SetupHostCommand,perl,Please install Perl 5.x, \
$(eval $(call CleanupPython2))
$(eval $(call SetupHostCommand,python,Please install Python >= 3.5, \
- python3.7 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?', \
- python3.6 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?', \
- python3.5 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?', \
+ python3.7 -V 2>&1 | grep 'Python 3', \
+ python3.6 -V 2>&1 | grep 'Python 3', \
+ python3.5 -V 2>&1 | grep 'Python 3', \
python3 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?'))
$(eval $(call SetupHostCommand,python3,Please install Python >= 3.5, \
- python3.7 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?', \
- python3.6 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?', \
- python3.5 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?', \
+ python3.7 -V 2>&1 | grep 'Python 3', \
+ python3.6 -V 2>&1 | grep 'Python 3', \
+ python3.5 -V 2>&1 | grep 'Python 3', \
python3 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?'))
$(eval $(call SetupHostCommand,git,Please install Git (git-core) >= 1.7.12.2, \