aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/linux/ramips/image/mt7621.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 4e3390a4ac..95fdc6095d 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -26,7 +26,7 @@ define Build/iodata-factory
mv $(factory_bin).new $(factory_bin); \
$(CP) $(factory_bin) $(BIN_DIR)/; \
else \
- echo "WARNING: initramfs kernel image too big, cannot generate factory image" >&2; \
+ echo "WARNING: initramfs kernel image too big, cannot generate factory image (actual $$(stat -c%s $@); max $(fw_size))" >&2; \
fi
endef
@@ -66,7 +66,7 @@ define Build/ubnt-erx-factory-image
\
$(CP) $(1) $(BIN_DIR)/; \
else \
- echo "WARNING: initramfs kernel image too big, cannot generate factory image" >&2; \
+ echo "WARNING: initramfs kernel image too big, cannot generate factory image (actual $$(stat -c%s $@); max $(KERNEL_SIZE))" >&2; \
fi
endef