aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/linux/ipq40xx/base-files/etc/uci-defaults/05_fix-compat-version10
-rw-r--r--target/linux/ipq40xx/image/generic.mk5
2 files changed, 14 insertions, 1 deletions
diff --git a/target/linux/ipq40xx/base-files/etc/uci-defaults/05_fix-compat-version b/target/linux/ipq40xx/base-files/etc/uci-defaults/05_fix-compat-version
new file mode 100644
index 0000000000..44873b9df4
--- /dev/null
+++ b/target/linux/ipq40xx/base-files/etc/uci-defaults/05_fix-compat-version
@@ -0,0 +1,10 @@
+. /lib/functions.sh
+
+case "$(board_name)" in
+ezviz,cs-w3-wd1200g-eup)
+ uci set system.@system[0].compat_version="2.0"
+ uci commit system
+ ;;
+esac
+
+exit 0
diff --git a/target/linux/ipq40xx/image/generic.mk b/target/linux/ipq40xx/image/generic.mk
index 872c4f957f..332fff7f45 100644
--- a/target/linux/ipq40xx/image/generic.mk
+++ b/target/linux/ipq40xx/image/generic.mk
@@ -493,13 +493,16 @@ define Device/ezviz_cs-w3-wd1200g-eup
DEVICE_VENDOR := EZVIZ
DEVICE_MODEL := CS-W3-WD1200G
DEVICE_VARIANT := EUP
- DEVICE_DTS_CONFIG := config@4
IMAGE_SIZE := 14848k
+ KERNEL_SIZE = 6m
SOC := qcom-ipq4018
IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | \
append-metadata
DEVICE_PACKAGES := -kmod-ath10k-ct kmod-ath10k-ct-smallbuffers \
ipq-wifi-ezviz_cs-w3-wd1200g-eup
+ DEVICE_COMPAT_VERSION := 2.0
+ DEVICE_COMPAT_MESSAGE := uboot's bootcmd has to be updated (see wiki). \
+ Upgrade via sysupgrade mechanism is not possible.
endef
TARGET_DEVICES += ezviz_cs-w3-wd1200g-eup