aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/utils/ucode/Makefile2
-rw-r--r--package/utils/ucode/patches/100-fix-int-format-on-32bit-system.patch11
2 files changed, 12 insertions, 1 deletions
diff --git a/package/utils/ucode/Makefile b/package/utils/ucode/Makefile
index 2c11fe05be..beafb94bb4 100644
--- a/package/utils/ucode/Makefile
+++ b/package/utils/ucode/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=ucode
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL=https://github.com/jow-/ucode.git
diff --git a/package/utils/ucode/patches/100-fix-int-format-on-32bit-system.patch b/package/utils/ucode/patches/100-fix-int-format-on-32bit-system.patch
new file mode 100644
index 0000000000..c557d0c1bd
--- /dev/null
+++ b/package/utils/ucode/patches/100-fix-int-format-on-32bit-system.patch
@@ -0,0 +1,11 @@
+--- a/lib.c
++++ b/lib.c
+@@ -1438,7 +1438,7 @@ uc_printf_common(uc_vm_t *vm, size_t nar
+
+ switch (t) {
+ case UC_INTEGER:
+- ucv_stringbuf_printf(buf, sfmt, arg.n);
++ ucv_stringbuf_printf(buf, sfmt, (int)arg.n);
+ break;
+
+ case UC_DOUBLE: