aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/boot/uboot-mvebu/Makefile4
-rw-r--r--target/linux/mvebu/image/Makefile2
2 files changed, 3 insertions, 3 deletions
diff --git a/package/boot/uboot-mvebu/Makefile b/package/boot/uboot-mvebu/Makefile
index e0cd944be9..bd95f769e9 100644
--- a/package/boot/uboot-mvebu/Makefile
+++ b/package/boot/uboot-mvebu/Makefile
@@ -31,8 +31,8 @@ UBOOT_TARGETS:= \
clearfog
define Build/InstallDev
- $(INSTALL_DIR) $(KERNEL_BUILD_DIR)/
- $(CP) $(PKG_BUILD_DIR)/$(UBOOT_IMAGE) $(KERNEL_BUILD_DIR)/$(BUILD_VARIANT)-u-boot-spl.kwb
+ $(INSTALL_DIR) $(STAGING_DIR_IMAGE)
+ $(CP) $(PKG_BUILD_DIR)/$(UBOOT_IMAGE) $(STAGING_DIR_IMAGE)/$(BUILD_VARIANT)-u-boot-spl.kwb
endef
$(eval $(call BuildPackage/U-Boot))
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index 96df359a61..16d93340d5 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -39,7 +39,7 @@ endef
define Build/sdcard-img
ROOTFS_SIZE=$$(( $(CONFIG_TARGET_ROOTFS_PARTSIZE) * 1024 * 2 )); \
./gen_mvebu_sdcard_img.sh $@ \
- "$(KDIR)/clearfog-u-boot-spl.kwb" \
+ "$(STAGING_DIR_IMAGE)/clearfog-u-boot-spl.kwb" \
c 32768 $@.boot \
83 $$ROOTFS_SIZE $(IMAGE_ROOTFS)
endef