aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/image-commands.mk4
-rw-r--r--target/linux/apm821xx/image/Makefile4
-rw-r--r--target/linux/mpc85xx/image/Makefile4
3 files changed, 4 insertions, 8 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 913e1c2411..158af853a5 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -196,6 +196,10 @@ define Build/check-size
}
endef
+define Build/copy-file
+ cat "$(1)" > "$@"
+endef
+
define Build/elecom-product-header
$(eval product=$(word 1,$(1)))
$(eval fw=$(if $(word 2,$(1)),$(word 2,$(1)),$@))
diff --git a/target/linux/apm821xx/image/Makefile b/target/linux/apm821xx/image/Makefile
index 2737a32436..f4701e9f26 100644
--- a/target/linux/apm821xx/image/Makefile
+++ b/target/linux/apm821xx/image/Makefile
@@ -28,10 +28,6 @@ define Build/boot-script
$@.scr
endef
-define Build/copy-file
- cat "$(1)" > "$@"
-endef
-
define Build/dtb
$(call Image/BuildDTB,../dts/$(DEVICE_DTS).dts,$@.dtb,,--space $(DTB_SIZE))
endef
diff --git a/target/linux/mpc85xx/image/Makefile b/target/linux/mpc85xx/image/Makefile
index b9582a2552..2b81884032 100644
--- a/target/linux/mpc85xx/image/Makefile
+++ b/target/linux/mpc85xx/image/Makefile
@@ -3,10 +3,6 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
-define Build/copy-file
- cat "$(1)" > "$@"
-endef
-
define Device/Default
PROFILES := Default
DEVICE_DTS := $(lastword $(subst _, ,$(1)))