aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--config/Config-images.in8
-rw-r--r--package/base-files/Makefile5
2 files changed, 13 insertions, 0 deletions
diff --git a/config/Config-images.in b/config/Config-images.in
index 4a7f08824b..92720fb84d 100644
--- a/config/Config-images.in
+++ b/config/Config-images.in
@@ -303,4 +303,12 @@ menu "Target Images"
it will be mounted by PARTUUID which makes the kernel find the
appropriate disk automatically.
+ config TARGET_ROOTFS_PERSIST_VAR
+ bool "Make /var persistent"
+ default n
+ help
+ Do not symlink /var to /tmp, so that its content will persist
+ across reboots. When enabled, /var/run will still be linked
+ to /tmp/run.
+
endmenu
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index d67f551b9c..6da3df2b4e 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -181,8 +181,13 @@ define Package/base-files/install
mkdir -p $(1)/www
mkdir -p $(1)/root
$(LN) /proc/mounts $(1)/etc/mtab
+ifeq ($(CONFIG_TARGET_ROOTFS_PERSIST_VAR),n)
rm -f $(1)/var
$(LN) tmp $(1)/var
+else
+ mkdir -p $(1)/var
+ $(LN) /tmp/run $(1)/var/run
+endif
mkdir -p $(1)/etc
$(LN) /tmp/resolv.conf /tmp/TZ /tmp/localtime $(1)/etc/