aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/apm821xx/patches-5.10/802-usb-xhci-force-msi-renesas-xhci.patch2
-rw-r--r--target/linux/bcm27xx/patches-5.10/950-0355-xhci-quirks-add-link-TRB-quirk-for-VL805.patch2
-rw-r--r--target/linux/bcm27xx/patches-5.10/950-0537-clk-Introduce-a-clock-request-API.patch2
-rw-r--r--target/linux/bcm27xx/patches-5.10/950-0689-drm-automatic-legacy-gamma-support.patch2
-rw-r--r--target/linux/generic/backport-5.10/732-net-next-1-of-net-pass-the-dst-buffer-to-of_get_mac_address.patch4
-rw-r--r--target/linux/mpc85xx/patches-5.10/002-powerpc-85xx-fix-oops-when-CONFIG_FSL_PMC-n.patch55
7 files changed, 8 insertions, 63 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 08c4bc85d0..ae0d01e74d 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -7,10 +7,10 @@ ifdef CONFIG_TESTING_KERNEL
endif
LINUX_VERSION-5.4 = .167
-LINUX_VERSION-5.10 = .87
+LINUX_VERSION-5.10 = .88
LINUX_KERNEL_HASH-5.4.167 = b4e43116217ee02009aba7eab3081e64560b81ce42bc6096fcd81257f470a5a7
-LINUX_KERNEL_HASH-5.10.87 = 03128b70f3063433cfab4ff4c7da288d7c045fe1eafa2a59081df4032fece64b
+LINUX_KERNEL_HASH-5.10.88 = 6f8631b6c382a2b0cfeff1e5f8805c8e1cfbe8d714b6e65f5bb79733c99068eb
remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
diff --git a/target/linux/apm821xx/patches-5.10/802-usb-xhci-force-msi-renesas-xhci.patch b/target/linux/apm821xx/patches-5.10/802-usb-xhci-force-msi-renesas-xhci.patch
index 1d7fe48489..daaf46bc5f 100644
--- a/target/linux/apm821xx/patches-5.10/802-usb-xhci-force-msi-renesas-xhci.patch
+++ b/target/linux/apm821xx/patches-5.10/802-usb-xhci-force-msi-renesas-xhci.patch
@@ -13,7 +13,7 @@ produce a noisy warning.
--- a/drivers/usb/host/xhci-pci.c
+++ b/drivers/usb/host/xhci-pci.c
-@@ -274,6 +274,7 @@ static void xhci_pci_quirks(struct devic
+@@ -276,6 +276,7 @@ static void xhci_pci_quirks(struct devic
pdev->device == 0x0015) {
xhci->quirks |= XHCI_RESET_ON_RESUME;
xhci->quirks |= XHCI_ZERO_64B_REGS;
diff --git a/target/linux/bcm27xx/patches-5.10/950-0355-xhci-quirks-add-link-TRB-quirk-for-VL805.patch b/target/linux/bcm27xx/patches-5.10/950-0355-xhci-quirks-add-link-TRB-quirk-for-VL805.patch
index ec889df411..92a35bec92 100644
--- a/target/linux/bcm27xx/patches-5.10/950-0355-xhci-quirks-add-link-TRB-quirk-for-VL805.patch
+++ b/target/linux/bcm27xx/patches-5.10/950-0355-xhci-quirks-add-link-TRB-quirk-for-VL805.patch
@@ -22,7 +22,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.com>
--- a/drivers/usb/host/xhci-pci.c
+++ b/drivers/usb/host/xhci-pci.c
-@@ -286,6 +286,7 @@ static void xhci_pci_quirks(struct devic
+@@ -288,6 +288,7 @@ static void xhci_pci_quirks(struct devic
if (pdev->vendor == PCI_VENDOR_ID_VIA && pdev->device == 0x3483) {
xhci->quirks |= XHCI_LPM_SUPPORT;
xhci->quirks |= XHCI_EP_CTX_BROKEN_DCS;
diff --git a/target/linux/bcm27xx/patches-5.10/950-0537-clk-Introduce-a-clock-request-API.patch b/target/linux/bcm27xx/patches-5.10/950-0537-clk-Introduce-a-clock-request-API.patch
index ba14120aa9..a73c9ca823 100644
--- a/target/linux/bcm27xx/patches-5.10/950-0537-clk-Introduce-a-clock-request-API.patch
+++ b/target/linux/bcm27xx/patches-5.10/950-0537-clk-Introduce-a-clock-request-API.patch
@@ -254,7 +254,7 @@ Signed-off-by: Maxime Ripard <maxime@cerno.tech>
* clk_get_parent - return the parent of a clk
* @clk: the clk whose parent gets returned
*
-@@ -3811,6 +3931,7 @@ __clk_register(struct device *dev, struc
+@@ -3820,6 +3940,7 @@ __clk_register(struct device *dev, struc
goto fail_parents;
INIT_HLIST_HEAD(&core->clks);
diff --git a/target/linux/bcm27xx/patches-5.10/950-0689-drm-automatic-legacy-gamma-support.patch b/target/linux/bcm27xx/patches-5.10/950-0689-drm-automatic-legacy-gamma-support.patch
index d7e598691d..50c0f71318 100644
--- a/target/linux/bcm27xx/patches-5.10/950-0689-drm-automatic-legacy-gamma-support.patch
+++ b/target/linux/bcm27xx/patches-5.10/950-0689-drm-automatic-legacy-gamma-support.patch
@@ -82,7 +82,7 @@ Link: https://patchwork.freedesktop.org/patch/msgid/20201211114237.213288-2-tomi
.atomic_duplicate_state = drm_atomic_helper_crtc_duplicate_state,
--- a/drivers/gpu/drm/ast/ast_mode.c
+++ b/drivers/gpu/drm/ast/ast_mode.c
-@@ -898,7 +898,6 @@ static void ast_crtc_atomic_destroy_stat
+@@ -901,7 +901,6 @@ static void ast_crtc_atomic_destroy_stat
static const struct drm_crtc_funcs ast_crtc_funcs = {
.reset = ast_crtc_reset,
diff --git a/target/linux/generic/backport-5.10/732-net-next-1-of-net-pass-the-dst-buffer-to-of_get_mac_address.patch b/target/linux/generic/backport-5.10/732-net-next-1-of-net-pass-the-dst-buffer-to-of_get_mac_address.patch
index 794d87dc6e..fff6b25ac5 100644
--- a/target/linux/generic/backport-5.10/732-net-next-1-of-net-pass-the-dst-buffer-to-of_get_mac_address.patch
+++ b/target/linux/generic/backport-5.10/732-net-next-1-of-net-pass-the-dst-buffer-to-of_get_mac_address.patch
@@ -334,7 +334,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
}
--- a/drivers/net/ethernet/broadcom/bcmsysport.c
+++ b/drivers/net/ethernet/broadcom/bcmsysport.c
-@@ -2465,7 +2465,6 @@ static int bcm_sysport_probe(struct plat
+@@ -2468,7 +2468,6 @@ static int bcm_sysport_probe(struct plat
struct bcm_sysport_priv *priv;
struct device_node *dn;
struct net_device *dev;
@@ -342,7 +342,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
u32 txq, rxq;
int ret;
-@@ -2560,12 +2559,10 @@ static int bcm_sysport_probe(struct plat
+@@ -2563,12 +2562,10 @@ static int bcm_sysport_probe(struct plat
}
/* Initialize netdevice members */
diff --git a/target/linux/mpc85xx/patches-5.10/002-powerpc-85xx-fix-oops-when-CONFIG_FSL_PMC-n.patch b/target/linux/mpc85xx/patches-5.10/002-powerpc-85xx-fix-oops-when-CONFIG_FSL_PMC-n.patch
deleted file mode 100644
index e9c2ec7032..0000000000
--- a/target/linux/mpc85xx/patches-5.10/002-powerpc-85xx-fix-oops-when-CONFIG_FSL_PMC-n.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-From e7757563e621522f5cd862b3aff473aedf8b66c0 Mon Sep 17 00:00:00 2001
-From: Xiaoming Ni <nixiaoming@huawei.com>
-Date: Fri, 26 Nov 2021 12:11:53 +0800
-Subject: [PATCH] powerpc/85xx: fix oops when CONFIG_FSL_PMC=n
-
-When CONFIG_FSL_PMC is set to n, no value is assigned to cpu_up_prepare
- in the mpc85xx_pm_ops structure. As a result, oops is triggered in
- smp_85xx_start_cpu().
-
- [ 0.627233] smp: Bringing up secondary CPUs ...
- [ 0.681659] kernel tried to execute user page (0) - exploit attempt? (uid: 0)
- [ 0.766618] BUG: Unable to handle kernel instruction fetch (NULL pointer?)
- [ 0.848899] Faulting instruction address: 0x00000000
- [ 0.908273] Oops: Kernel access of bad area, sig: 11 [#1]
- ...
- [ 1.758220] NIP [00000000] 0x0
- [ 1.794688] LR [c0021d2c] smp_85xx_kick_cpu+0xe8/0x568
- [ 1.856126] Call Trace:
- [ 1.885295] [c1051da8] [c0021cb8] smp_85xx_kick_cpu+0x74/0x568 (unreliable)
- [ 1.968633] [c1051de8] [c0011460] __cpu_up+0xc0/0x228
- [ 2.029038] [c1051e18] [c0031bbc] bringup_cpu+0x30/0x224
- [ 2.092572] [c1051e48] [c0031f3c] cpu_up.constprop.0+0x180/0x33c
- [ 2.164443] [c1051e88] [c00322e8] bringup_nonboot_cpus+0x88/0xc8
- [ 2.236326] [c1051eb8] [c07e67bc] smp_init+0x30/0x78
- [ 2.295698] [c1051ed8] [c07d9e28] kernel_init_freeable+0x118/0x2a8
- [ 2.369641] [c1051f18] [c00032d8] kernel_init+0x14/0x124
- [ 2.433176] [c1051f38] [c0010278] ret_from_kernel_thread+0x14/0x1c
-
-Fixes: c45361abb9185b ("powerpc/85xx: fix timebase sync issue when
- CONFIG_HOTPLUG_CPU=n")
-Link: https://lore.kernel.org/lkml/CANA18Uyba4kMJQrbCSZVTFep2Exe5izE45whNJgwwUvNSEcNLg@mail.gmail.com/
-Reported-by: Martin Kennedy <hurricos@gmail.com>
-Signed-off-by: Xiaoming Ni <nixiaoming@huawei.com>
-Tested-by: Martin Kennedy <hurricos@gmail.com>
-Cc: stable@vger.kernel.org
---- a/arch/powerpc/platforms/85xx/smp.c
-+++ b/arch/powerpc/platforms/85xx/smp.c
-@@ -220,7 +220,7 @@ static int smp_85xx_start_cpu(int cpu)
- local_irq_save(flags);
- hard_irq_disable();
-
-- if (qoriq_pm_ops)
-+ if (qoriq_pm_ops && qoriq_pm_ops->cpu_up_prepare)
- qoriq_pm_ops->cpu_up_prepare(cpu);
-
- /* if cpu is not spinning, reset it */
-@@ -292,7 +292,7 @@ static int smp_85xx_kick_cpu(int nr)
- booting_thread_hwid = cpu_thread_in_core(nr);
- primary = cpu_first_thread_sibling(nr);
-
-- if (qoriq_pm_ops)
-+ if (qoriq_pm_ops && qoriq_pm_ops->cpu_up_prepare)
- qoriq_pm_ops->cpu_up_prepare(nr);
-
- /*