aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/generic/hack-5.10/205-kconfig-exit.patch2
-rw-r--r--target/linux/generic/hack-5.10/904-debloat_dma_buf.patch2
-rw-r--r--target/linux/generic/pending-5.10/683-of_net-add-mac-address-to-of-tree.patch4
-rw-r--r--target/linux/mediatek/patches-5.10/410-bt-mtk-serial-fix.patch2
5 files changed, 7 insertions, 7 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 7e5798861b..9afb6ea632 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -7,10 +7,10 @@ ifdef CONFIG_TESTING_KERNEL
endif
LINUX_VERSION-5.4 = .138
-LINUX_VERSION-5.10 = .57
+LINUX_VERSION-5.10 = .58
LINUX_KERNEL_HASH-5.4.138 = a43957727a54e5e1035d7372a1e64203ae8e3060c52a3816916157967f9a8657
-LINUX_KERNEL_HASH-5.10.57 = 00bbaeaac17f82d9a6d93cbc42cafd39d3b2fa3a6087333503d2344fa5e3142d
+LINUX_KERNEL_HASH-5.10.58 = 732cc56be539e65894621c3b6b2640597d8cf5da17319b82da6e7b4f7828f210
remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
diff --git a/target/linux/generic/hack-5.10/205-kconfig-exit.patch b/target/linux/generic/hack-5.10/205-kconfig-exit.patch
index 8931ad3270..c3fb7a1f99 100644
--- a/target/linux/generic/hack-5.10/205-kconfig-exit.patch
+++ b/target/linux/generic/hack-5.10/205-kconfig-exit.patch
@@ -1,6 +1,6 @@
--- a/scripts/kconfig/conf.c
+++ b/scripts/kconfig/conf.c
-@@ -212,6 +212,8 @@ static int conf_sym(struct menu *menu)
+@@ -215,6 +215,8 @@ static int conf_sym(struct menu *menu)
break;
continue;
case 0:
diff --git a/target/linux/generic/hack-5.10/904-debloat_dma_buf.patch b/target/linux/generic/hack-5.10/904-debloat_dma_buf.patch
index 2f5f685063..4ed40bb63d 100644
--- a/target/linux/generic/hack-5.10/904-debloat_dma_buf.patch
+++ b/target/linux/generic/hack-5.10/904-debloat_dma_buf.patch
@@ -62,7 +62,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
+MODULE_LICENSE("GPL");
--- a/kernel/sched/core.c
+++ b/kernel/sched/core.c
-@@ -3051,6 +3051,7 @@ int wake_up_state(struct task_struct *p,
+@@ -3049,6 +3049,7 @@ int wake_up_state(struct task_struct *p,
{
return try_to_wake_up(p, state, 0);
}
diff --git a/target/linux/generic/pending-5.10/683-of_net-add-mac-address-to-of-tree.patch b/target/linux/generic/pending-5.10/683-of_net-add-mac-address-to-of-tree.patch
index ea5883f037..02f7519f74 100644
--- a/target/linux/generic/pending-5.10/683-of_net-add-mac-address-to-of-tree.patch
+++ b/target/linux/generic/pending-5.10/683-of_net-add-mac-address-to-of-tree.patch
@@ -1,6 +1,6 @@
--- a/drivers/of/of_net.c
+++ b/drivers/of/of_net.c
-@@ -135,6 +135,26 @@ static int of_get_mac_address_mtd(struct
+@@ -141,6 +141,26 @@ static int of_get_mac_address_mtd(struct
return -EINVAL;
}
@@ -27,7 +27,7 @@
/**
* Search the device tree for the best MAC address to use. 'mac-address' is
-@@ -210,6 +230,7 @@ found:
+@@ -216,6 +236,7 @@ found:
if (!of_property_read_u32(np, "mac-address-increment", &mac_inc))
addr[inc_idx] += mac_inc;
diff --git a/target/linux/mediatek/patches-5.10/410-bt-mtk-serial-fix.patch b/target/linux/mediatek/patches-5.10/410-bt-mtk-serial-fix.patch
index 381eaab5e2..b82e174d27 100644
--- a/target/linux/mediatek/patches-5.10/410-bt-mtk-serial-fix.patch
+++ b/target/linux/mediatek/patches-5.10/410-bt-mtk-serial-fix.patch
@@ -19,7 +19,7 @@
},
[PORT_NPCM] = {
.name = "Nuvoton 16550",
-@@ -2712,6 +2712,11 @@ serial8250_do_set_termios(struct uart_po
+@@ -2718,6 +2718,11 @@ serial8250_do_set_termios(struct uart_po
unsigned long flags;
unsigned int baud, quot, frac = 0;