aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/boot/at91bootstrap/Makefile14
-rw-r--r--package/boot/uboot-at91/Makefile14
-rw-r--r--target/linux/at91/image/sama5.mk11
3 files changed, 39 insertions, 0 deletions
diff --git a/package/boot/at91bootstrap/Makefile b/package/boot/at91bootstrap/Makefile
index 56e14c5770..8711acd286 100644
--- a/package/boot/at91bootstrap/Makefile
+++ b/package/boot/at91bootstrap/Makefile
@@ -118,6 +118,18 @@ define AT91Bootstrap/sama5d27_som1_ekqspi_uboot
BUILD_DEVICES:=microchip_sama5d27-som1-ek
endef
+define AT91Bootstrap/sama5d27_wlsom1_eksd_uboot
+ TITLE:=AT91Bootstrap for SAMA5D27 WLSOM1 Ek (SDcard0)
+ BUILD_SUBTARGET:=sama5
+ BUILD_DEVICES:=microchip_sama5d27-wlsom1-ek
+endef
+
+define AT91Bootstrap/sama5d27_wlsom1_ekdf_qspi_uboot
+ TITLE:=AT91Bootstrap for SAMA5D27 WLSOM1 Ek (QSPI Flash)
+ BUILD_SUBTARGET:=sama5
+ BUILD_DEVICES:=microchip_sama5d27-wlsom1-ek
+endef
+
define AT91Bootstrap/sama5d2_ptc_eknf_uboot
TITLE:=AT91Bootstrap for SAMA5D2 PTC EK (Nand Flash)
BUILD_SUBTARGET:=sama5
@@ -145,6 +157,8 @@ AT91BOOTSTRAP_TARGETS := \
sama5d4_xplainedsd_uboot_secure \
sama5d27_som1_eksd1_uboot \
sama5d27_som1_ekqspi_uboot \
+ sama5d27_wlsom1_eksd_uboot \
+ sama5d27_wlsom1_ekdf_qspi_uboot \
sama5d2_ptc_eknf_uboot \
sama5d2_ptc_eksd_uboot
diff --git a/package/boot/uboot-at91/Makefile b/package/boot/uboot-at91/Makefile
index 822d71f796..3262da4cbe 100644
--- a/package/boot/uboot-at91/Makefile
+++ b/package/boot/uboot-at91/Makefile
@@ -107,6 +107,18 @@ define U-Boot/sama5d27_som1_ek_qspiflash
BUILD_DEVICES:=microchip_sama5d27-som1-ek
endef
+define U-Boot/sama5d27_wlsom1_ek_mmc
+ NAME:=SAMA5D27 WLSOM1 Ek (SDCard)
+ BUILD_SUBTARGET:=sama5
+ BUILD_DEVICES:=microchip_sama5d27-wlsom1-ek
+endef
+
+define U-Boot/sama5d27_wlsom1_ek_qspiflash
+ NAME:=SAMA5D27 WLSOM1 Ek (QSPI Flash)
+ BUILD_SUBTARGET:=sama5
+ BUILD_DEVICES:=microchip_sama5d27-wlsom1-ek
+endef
+
define U-Boot/sama5d2_ptc_ek_nandflash
NAME:=SAMA5D2 PTC Ek (Nand Flash)
BUILD_SUBTARGET:=sama5
@@ -133,6 +145,8 @@ UBOOT_TARGETS := \
sama5d4_xplained_nandflash\
sama5d27_som1_ek_mmc1 \
sama5d27_som1_ek_qspiflash \
+ sama5d27_wlsom1_ek_mmc \
+ sama5d27_wlsom1_ek_qspiflash \
sama5d2_ptc_ek_nandflash \
sama5d2_ptc_ek_mmc
diff --git a/target/linux/at91/image/sama5.mk b/target/linux/at91/image/sama5.mk
index ae34943321..9078db525f 100644
--- a/target/linux/at91/image/sama5.mk
+++ b/target/linux/at91/image/sama5.mk
@@ -87,6 +87,17 @@ define Device/microchip_sama5d27-som1-ek
endef
TARGET_DEVICES += microchip_sama5d27-som1-ek
+define Device/microchip_sama5d27-wlsom1-ek
+ $(Device/evaluation-dtb)
+ DEVICE_VENDOR := Microchip
+ DEVICE_MODEL := SAMA5D27 WSOM1 Ek
+ DEVICE_DTS := at91-sama5d27_wlsom1_ek
+ SUPPORTED_DEVICES := microchip,sama5d27-wlsom1-ek
+ KERNEL_SIZE := 6144k
+ $(Device/evaluation-sdimage)
+endef
+TARGET_DEVICES += microchip_sama5d27-wlsom1-ek
+
define Device/microchip_sama5d2-ptc-ek
$(Device/evaluation-dtb)
DEVICE_VENDOR := Microchip