aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--tools/findutils/Makefile4
-rw-r--r--tools/findutils/patches/010-endpwent.patch20
2 files changed, 22 insertions, 2 deletions
diff --git a/tools/findutils/Makefile b/tools/findutils/Makefile
index 37cd897355..d0d780689b 100644
--- a/tools/findutils/Makefile
+++ b/tools/findutils/Makefile
@@ -8,11 +8,11 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=findutils
PKG_CPE_ID:=cpe:/a:gnu:findutils
-PKG_VERSION:=4.8.0
+PKG_VERSION:=4.9.0
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
-PKG_HASH:=57127b7e97d91282c6ace556378d5455a9509898297e46e10443016ea1387164
+PKG_HASH:=a2bfb8c09d436770edc59f50fa483e785b161a3b7b9d547573cb08065fd462fe
HOST_BUILD_PARALLEL:=1
diff --git a/tools/findutils/patches/010-endpwent.patch b/tools/findutils/patches/010-endpwent.patch
new file mode 100644
index 0000000000..dc346f3f76
--- /dev/null
+++ b/tools/findutils/patches/010-endpwent.patch
@@ -0,0 +1,20 @@
+--- a/find/parser.c
++++ b/find/parser.c
+@@ -67,12 +67,12 @@
+ #include "findutils-version.h"
+ #include "system.h"
+
+-
+-#ifndef HAVE_ENDGRENT
+-# define endgrent ()
++#if ! HAVE_ENDGRENT
++# define endgrent() ((void) 0)
+ #endif
+-#ifndef HAVE_ENDPWENT
+-# define endpwent ()
++
++#if ! HAVE_ENDPWENT
++# define endpwent() ((void) 0)
+ #endif
+
+ static bool parse_accesscheck (const struct parser_table*, char *argv[], int *arg_ptr);