aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/linux/ramips/image/mt7621.mk7
1 files changed, 4 insertions, 3 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 860b33d1dd..5f6ef8cb76 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -9,9 +9,10 @@ DEFAULT_SOC := mt7621
KERNEL_DTB += -d21
DEVICE_VARS += ELECOM_HWNAME LINKSYS_HWNAME
-define Build/beeline-trx
+define Build/arcadyan-trx
echo -ne "hsqs" > $@.hsqs
- $(STAGING_DIR_HOST)/bin/otrx create $@.trx -M 0x746f435d -f $@ \
+ $(eval trx_magic=$(word 1,$(1)))
+ $(STAGING_DIR_HOST)/bin/otrx create $@.trx -M $(trx_magic) -f $@ \
-a 0x20000 -b 0x420000 -f $@.hsqs -a 1000
mv $@.trx $@
dd if=/dev/zero bs=1024 count=1 >> $@.tail
@@ -255,7 +256,7 @@ define Device/beeline_smartbox-flash
BLOCKSIZE := 128k
PAGESIZE := 2048
KERNEL := kernel-bin | append-dtb | lzma | loader-kernel | \
- uImage none | beeline-trx | pad-to $$(KERNEL_SIZE)
+ uImage none | arcadyan-trx 0x746f435d | pad-to $$(KERNEL_SIZE)
KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | loader-kernel | \
uImage none
IMAGES += factory.trx