aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/network/services/hostapd/Makefile2
-rw-r--r--package/network/services/hostapd/files/hostapd.sh6
2 files changed, 6 insertions, 2 deletions
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index b7cc6b9c34..8a1f083217 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=hostapd
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE_URL:=http://w1.fi/hostap.git
PKG_SOURCE_PROTO:=git
diff --git a/package/network/services/hostapd/files/hostapd.sh b/package/network/services/hostapd/files/hostapd.sh
index 86e9a32e5b..2c015f9c4b 100644
--- a/package/network/services/hostapd/files/hostapd.sh
+++ b/package/network/services/hostapd/files/hostapd.sh
@@ -66,6 +66,8 @@ hostapd_common_add_device_config() {
config_add_string require_mode
config_add_boolean legacy_rates
+ config_add_string acs_chan_bias
+
hostapd_add_log_config
}
@@ -76,7 +78,7 @@ hostapd_prepare_device_config() {
local base="${config%%.conf}"
local base_cfg=
- json_get_vars country country_ie beacon_int:100 doth require_mode legacy_rates
+ json_get_vars country country_ie beacon_int:100 doth require_mode legacy_rates acs_chan_bias
hostapd_set_log_options base_cfg
@@ -93,6 +95,8 @@ hostapd_prepare_device_config() {
[ "$hwmode" = "a" -a "$doth" -gt 0 ] && append base_cfg "ieee80211h=1" "$N"
}
+ [ -n "$acs_chan_bias" ] && append base_cfg "acs_chan_bias=$acs_chan_bias" "$N"
+
local brlist= br
json_get_values basic_rate_list basic_rate
local rlist= r