aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/linux/ramips/dts/mt7628an_tplink_re200-v4.dts8
-rw-r--r--target/linux/ramips/image/mt76x8.mk10
-rwxr-xr-xtarget/linux/ramips/mt76x8/base-files/etc/board.d/01_leds1
-rwxr-xr-xtarget/linux/ramips/mt76x8/base-files/etc/board.d/02_network1
-rw-r--r--tools/firmware-utils/src/tplink-safeloader.c44
5 files changed, 64 insertions, 0 deletions
diff --git a/target/linux/ramips/dts/mt7628an_tplink_re200-v4.dts b/target/linux/ramips/dts/mt7628an_tplink_re200-v4.dts
new file mode 100644
index 0000000000..83f1f3acca
--- /dev/null
+++ b/target/linux/ramips/dts/mt7628an_tplink_re200-v4.dts
@@ -0,0 +1,8 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "mt7628an_tplink_re200.dtsi"
+
+/ {
+ compatible = "tplink,re200-v4", "mediatek,mt7628an-soc";
+ model = "TP-Link RE200 v4";
+};
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index 326dcd82bb..6327c95bb0 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -413,6 +413,16 @@ define Device/tplink_re200-v3
endef
TARGET_DEVICES += tplink_re200-v3
+define Device/tplink_re200-v4
+ $(Device/tplink-safeloader)
+ IMAGE_SIZE := 7808k
+ DEVICE_MODEL := RE200
+ DEVICE_VARIANT := v4
+ DEVICE_PACKAGES := kmod-mt76x0e
+ TPLINK_BOARD_ID := RE200-V4
+endef
+TARGET_DEVICES += tplink_re200-v4
+
define Device/tplink_re220-v2
$(Device/tplink-safeloader)
IMAGE_SIZE := 7808k
diff --git a/target/linux/ramips/mt76x8/base-files/etc/board.d/01_leds b/target/linux/ramips/mt76x8/base-files/etc/board.d/01_leds
index c26d6436e9..e1c3454237 100755
--- a/target/linux/ramips/mt76x8/base-files/etc/board.d/01_leds
+++ b/target/linux/ramips/mt76x8/base-files/etc/board.d/01_leds
@@ -62,6 +62,7 @@ tplink,archer-c50-v4)
;;
tplink,re200-v2|\
tplink,re200-v3|\
+tplink,re200-v4|\
tplink,re220-v2|\
tplink,tl-mr3020-v3|\
tplink,tl-wa801nd-v5)
diff --git a/target/linux/ramips/mt76x8/base-files/etc/board.d/02_network b/target/linux/ramips/mt76x8/base-files/etc/board.d/02_network
index f1687c7108..2cda818b2a 100755
--- a/target/linux/ramips/mt76x8/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/mt76x8/base-files/etc/board.d/02_network
@@ -20,6 +20,7 @@ ramips_setup_interfaces()
tama,w06|\
tplink,re200-v2|\
tplink,re200-v3|\
+ tplink,re200-v4|\
tplink,re220-v2|\
tplink,re305-v1|\
tplink,tl-mr3020-v3|\
diff --git a/tools/firmware-utils/src/tplink-safeloader.c b/tools/firmware-utils/src/tplink-safeloader.c
index 31b9c032d1..22427a67e5 100644
--- a/tools/firmware-utils/src/tplink-safeloader.c
+++ b/tools/firmware-utils/src/tplink-safeloader.c
@@ -1774,6 +1774,50 @@ static struct device_info boards[] = {
.last_sysupgrade_partition = "file-system"
},
+ /** Firmware layout for the RE200 v4 */
+ {
+ .id = "RE200-V4",
+ .vendor = "",
+ .support_list =
+ "SupportList:\n"
+ "{product_name:RE200,product_ver:4.0.0,special_id:00000000}\n"
+ "{product_name:RE200,product_ver:4.0.0,special_id:45550000}\n"
+ "{product_name:RE200,product_ver:4.0.0,special_id:4A500000}\n"
+ "{product_name:RE200,product_ver:4.0.0,special_id:4B520000}\n"
+ "{product_name:RE200,product_ver:4.0.0,special_id:43410000}\n"
+ "{product_name:RE200,product_ver:4.0.0,special_id:41550000}\n"
+ "{product_name:RE200,product_ver:4.0.0,special_id:42520000}\n"
+ "{product_name:RE200,product_ver:4.0.0,special_id:55530000}\n"
+ "{product_name:RE200,product_ver:4.0.0,special_id:41520000}\n"
+ "{product_name:RE200,product_ver:4.0.0,special_id:52550000}\n"
+ "{product_name:RE200,product_ver:4.0.0,special_id:54570000}\n"
+ "{product_name:RE200,product_ver:4.0.0,special_id:45530000}\n"
+ "{product_name:RE200,product_ver:4.0.0,special_id:49440000}\n"
+ "{product_name:RE200,product_ver:4.0.0,special_id:45470000}\n",
+ .support_trail = '\x00',
+ .soft_ver = "soft_ver:1.1.0\n",
+
+ .partitions = {
+ {"fs-uboot", 0x00000, 0x20000},
+ {"firmware", 0x20000, 0x7a0000},
+ {"partition-table", 0x7c0000, 0x02000},
+ {"default-mac", 0x7c2000, 0x00020},
+ {"pin", 0x7c2100, 0x00020},
+ {"product-info", 0x7c3100, 0x01000},
+ {"soft-version", 0x7c4200, 0x01000},
+ {"support-list", 0x7c5200, 0x01000},
+ {"profile", 0x7c6200, 0x08000},
+ {"config-info", 0x7ce200, 0x00400},
+ {"user-config", 0x7d0000, 0x10000},
+ {"default-config", 0x7e0000, 0x10000},
+ {"radio", 0x7f0000, 0x10000},
+ {NULL, 0, 0}
+ },
+
+ .first_sysupgrade_partition = "os-image",
+ .last_sysupgrade_partition = "file-system"
+ },
+
/** Firmware layout for the RE220 v2 */
{
.id = "RE220-V2",