diff options
-rw-r--r-- | Makefile | 1 | ||||
-rw-r--r-- | include/scan.mk | 1 | ||||
-rw-r--r-- | include/target.mk | 1 |
3 files changed, 3 insertions, 0 deletions
@@ -15,6 +15,7 @@ empty:= space:= $(empty) $(empty) $(if $(findstring $(space),$(TOPDIR)),$(error ERROR: The path to the OpenWrt directory must not include any spaces)) +.ONESHELL: world: include $(TOPDIR)/include/host.mk diff --git a/include/scan.mk b/include/scan.mk index 0998333439..2f2753f2a0 100644 --- a/include/scan.mk +++ b/include/scan.mk @@ -78,3 +78,4 @@ $(TMP_DIR)/.$(SCAN_TARGET): $(TARGET_STAMP) $(SCAN_STAMP) FORCE: .PHONY: FORCE .NOTPARALLEL: +.ONESHELL: diff --git a/include/target.mk b/include/target.mk index 3401f849a5..657109e75d 100644 --- a/include/target.mk +++ b/include/target.mk @@ -19,6 +19,7 @@ DEFAULT_PACKAGES.bootloader:= ifneq ($(DUMP),) all: dumpinfo + .ONESHELL: endif target_conf=$(subst .,_,$(subst -,_,$(subst /,_,$(1)))) |