aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/linux/ramips/dts/mt7621_elecom_wrc-1750gs.dts41
-rw-r--r--target/linux/ramips/dts/mt7621_elecom_wrc-1750gsv.dts41
-rw-r--r--target/linux/ramips/image/mt7621.mk24
3 files changed, 106 insertions, 0 deletions
diff --git a/target/linux/ramips/dts/mt7621_elecom_wrc-1750gs.dts b/target/linux/ramips/dts/mt7621_elecom_wrc-1750gs.dts
new file mode 100644
index 0000000000..46d4c1a708
--- /dev/null
+++ b/target/linux/ramips/dts/mt7621_elecom_wrc-1750gs.dts
@@ -0,0 +1,41 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "mt7621_elecom_wrc-gst.dtsi"
+
+/ {
+ compatible = "elecom,wrc-1750gs", "mediatek,mt7621-soc";
+ model = "ELECOM WRC-1750GS";
+};
+
+&partitions {
+ partition@50000 {
+ compatible = "denx,uimage";
+ label = "firmware";
+ reg = <0x50000 0xb00000>;
+ };
+
+ partition@b50000 {
+ label = "tm_pattern";
+ reg = <0xb50000 0x380000>;
+ read-only;
+ };
+
+ partition@ed0000 {
+ label = "tm_key";
+ reg = <0xed0000 0x80000>;
+ read-only;
+ };
+
+ partition@f50000 {
+ label = "art_block";
+ reg = <0xf50000 0x30000>;
+ read-only;
+ };
+
+ partition@f80000 {
+ label = "user_data";
+ reg = <0xf80000 0x80000>;
+ read-only;
+ };
+};
diff --git a/target/linux/ramips/dts/mt7621_elecom_wrc-1750gsv.dts b/target/linux/ramips/dts/mt7621_elecom_wrc-1750gsv.dts
new file mode 100644
index 0000000000..6f2054b076
--- /dev/null
+++ b/target/linux/ramips/dts/mt7621_elecom_wrc-1750gsv.dts
@@ -0,0 +1,41 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "mt7621_elecom_wrc-gst.dtsi"
+
+/ {
+ compatible = "elecom,wrc-1750gsv", "mediatek,mt7621-soc";
+ model = "ELECOM WRC-1750GSV";
+};
+
+&partitions {
+ partition@50000 {
+ compatible = "denx,uimage";
+ label = "firmware";
+ reg = <0x50000 0xb00000>;
+ };
+
+ partition@b50000 {
+ label = "tm_pattern";
+ reg = <0xb50000 0x380000>;
+ read-only;
+ };
+
+ partition@ed0000 {
+ label = "tm_key";
+ reg = <0xed0000 0x80000>;
+ read-only;
+ };
+
+ partition@f50000 {
+ label = "nvram";
+ reg = <0xf50000 0x30000>;
+ read-only;
+ };
+
+ partition@f80000 {
+ label = "user_data";
+ reg = <0xf80000 0x80000>;
+ read-only;
+ };
+};
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 48561d5ff9..a16900aa8c 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -326,6 +326,30 @@ define Device/elecom_wrc-1167ghbk2-s
endef
TARGET_DEVICES += elecom_wrc-1167ghbk2-s
+define Device/elecom_wrc-1750gs
+ $(Device/uimage-lzma-loader)
+ IMAGE_SIZE := 11264k
+ DEVICE_VENDOR := ELECOM
+ DEVICE_MODEL := WRC-1750GS
+ IMAGES += factory.bin
+ IMAGE/factory.bin := $$(sysupgrade_bin) | check-size | \
+ elecom-gst-factory WRC-1750GS 0.00
+ DEVICE_PACKAGES := kmod-mt7615e kmod-mt7615-firmware wpad-basic
+endef
+TARGET_DEVICES += elecom_wrc-1750gs
+
+define Device/elecom_wrc-1750gsv
+ $(Device/uimage-lzma-loader)
+ IMAGE_SIZE := 11264k
+ DEVICE_VENDOR := ELECOM
+ DEVICE_MODEL := WRC-1750GSV
+ IMAGES += factory.bin
+ IMAGE/factory.bin := $$(sysupgrade_bin) | check-size | \
+ elecom-gst-factory WRC-1750GSV 0.00
+ DEVICE_PACKAGES := kmod-mt7615e kmod-mt7615-firmware wpad-basic
+endef
+TARGET_DEVICES += elecom_wrc-1750gsv
+
define Device/elecom_wrc-1900gst
$(Device/uimage-lzma-loader)
IMAGE_SIZE := 11264k