aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/linux/at91/image/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/target/linux/at91/image/Makefile b/target/linux/at91/image/Makefile
index 99c7e21669..93337097c0 100644
--- a/target/linux/at91/image/Makefile
+++ b/target/linux/at91/image/Makefile
@@ -16,7 +16,12 @@ endif
ifeq ($(SUBTARGET),sama5)
include ./sama5.mk
-UBIFS_OPTS := -m 2048 -e 124KiB -c 2048
+ifeq ($(TARGET_DEVICES),at91-sama5d4_xplained)
+ UBIFS_OPTS := -e 0x3e000 -c 2082 -m 0x1000 -x lzo
+ UBINIZE_OPTS := -m 0x1000 -p 0x40000
+else
+ UBIFS_OPTS := -m 2048 -e 124KiB -c 2048
+endif
endif
define Device/Default