aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xtarget/linux/ath79/base-files/etc/board.d/02_network5
-rwxr-xr-xtarget/linux/ath79/base-files/etc/board.d/03_gpio_switches3
-rw-r--r--target/linux/ath79/dts/qca9533_ubnt_acb-isp.dts95
-rw-r--r--target/linux/ath79/image/generic-ubnt.mk12
4 files changed, 115 insertions, 0 deletions
diff --git a/target/linux/ath79/base-files/etc/board.d/02_network b/target/linux/ath79/base-files/etc/board.d/02_network
index e399210b2b..4651669d31 100755
--- a/target/linux/ath79/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/base-files/etc/board.d/02_network
@@ -233,6 +233,11 @@ ath79_setup_interfaces()
tplink,tl-wr941-v2)
ucidef_set_interfaces_lan_wan "lan1 lan2 lan3 lan4" "wan"
;;
+ ubnt,acb-isp)
+ ucidef_set_interface_wan "eth0"
+ ucidef_add_switch "switch0" \
+ "0@eth1" "2:lan:1" "3:lan:3" "4:lan:2"
+ ;;
ubnt,routerstation-pro)
ucidef_set_interface_wan "eth0"
ucidef_add_switch "switch0" \
diff --git a/target/linux/ath79/base-files/etc/board.d/03_gpio_switches b/target/linux/ath79/base-files/etc/board.d/03_gpio_switches
index c852b77d79..6a51a79790 100755
--- a/target/linux/ath79/base-files/etc/board.d/03_gpio_switches
+++ b/target/linux/ath79/base-files/etc/board.d/03_gpio_switches
@@ -26,6 +26,9 @@ librerouter,librerouter-v1)
ubnt,nanostation-ac)
ucidef_add_gpio_switch "poe_passthrough" "PoE Passthrough" "3"
;;
+ubnt,acb-isp)
+ ucidef_add_gpio_switch "poe_passthrough" "PoE Passthrough" "11"
+ ;;
esac
board_config_flush
diff --git a/target/linux/ath79/dts/qca9533_ubnt_acb-isp.dts b/target/linux/ath79/dts/qca9533_ubnt_acb-isp.dts
new file mode 100644
index 0000000000..3bdaa8ba9b
--- /dev/null
+++ b/target/linux/ath79/dts/qca9533_ubnt_acb-isp.dts
@@ -0,0 +1,95 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "qca953x.dtsi"
+
+/ {
+ compatible = "ubnt,acb-isp", "qca,qca9533";
+ model = "Ubiquiti airCube ISP";
+
+ keys {
+ compatible = "gpio-keys";
+
+ reset {
+ label = "reset";
+ linux,code = <KEY_RESTART>;
+ gpios = <&gpio 17 GPIO_ACTIVE_LOW>;
+ debounce-interval = <60>;
+ };
+ };
+};
+
+&spi {
+ status = "okay";
+ num-cs = <1>;
+
+ flash@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <25000000>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x000000 0x040000>;
+ read-only;
+ };
+
+ partition@40000 {
+ label = "u-boot-env";
+ reg = <0x040000 0x010000>;
+ read-only;
+ };
+
+ partition@50000 {
+ compatible = "denx,uimage";
+ label = "firmware";
+ reg = <0x050000 0xf60000>;
+ };
+
+ partition@fb0000 {
+ label = "cfg";
+ reg = <0xfb0000 0x040000>;
+ read-only;
+ };
+
+ eeprom: partition@ff0000 {
+ label = "EEPROM";
+ reg = <0xff0000 0x010000>;
+ read-only;
+ };
+ };
+ };
+};
+
+&uart {
+ status = "okay";
+};
+
+&eth0 {
+ status = "okay";
+ mtd-mac-address = <&eeprom 0x0>;
+ phy-handle = <&swphy4>;
+};
+
+&eth1 {
+ status = "okay";
+ mtd-mac-address = <&eeprom 0x6>;
+
+ gmac-config {
+ device = <&gmac>;
+ };
+};
+
+&wmac {
+ status = "okay";
+ mtd-cal-data = <&eeprom 0x1000>;
+ mtd-mac-address = <&eeprom 0x1002>;
+};
diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index 8fddc0f1d0..b189d66770 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -229,3 +229,15 @@ define Device/ubnt_routerstation-pro
UBNT_CHIP := ar7100pro
endef
TARGET_DEVICES += ubnt_routerstation-pro
+
+define Device/ubnt_acb-isp
+ $(Device/ubnt)
+ ATH_SOC := qca9533
+ IMAGE_SIZE := 15744k
+ DEVICE_TITLE := Ubiquiti airCube ISP
+ UBNT_BOARD := ACB-ISP
+ UBNT_TYPE := ACB
+ UBNT_CHIP := qca9533
+ IMAGES := sysupgrade.bin
+endef
+TARGET_DEVICES += ubnt_acb-isp