aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/generic/hack-4.14/902-debloat_proc.patch2
-rw-r--r--target/linux/x86/64/config-default1
-rw-r--r--target/linux/x86/generic/config-default1
-rw-r--r--target/linux/x86/geode/config-default1
-rw-r--r--target/linux/x86/legacy/config-default1
6 files changed, 7 insertions, 3 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index ed74860702..37c48bdad6 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -3,10 +3,10 @@
LINUX_RELEASE?=1
LINUX_VERSION-4.9 = .189
-LINUX_VERSION-4.14 = .138
+LINUX_VERSION-4.14 = .139
LINUX_KERNEL_HASH-4.9.189 = 93d945661246f726b694455c80c140717d2beff5a718445a51183439bbe5d0b3
-LINUX_KERNEL_HASH-4.14.138 = f250bd1de3a83c1f015f8e6e9bfa9f20eaef3dc24a6cd60116e49979314b837b
+LINUX_KERNEL_HASH-4.14.139 = 8c62d495444dba90200740ec770d274780b010e957cfc447f07999d717e37042
remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
diff --git a/target/linux/generic/hack-4.14/902-debloat_proc.patch b/target/linux/generic/hack-4.14/902-debloat_proc.patch
index 72ee9c011e..f75b9721e5 100644
--- a/target/linux/generic/hack-4.14/902-debloat_proc.patch
+++ b/target/linux/generic/hack-4.14/902-debloat_proc.patch
@@ -233,7 +233,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
return -ENOMEM;
--- a/mm/vmalloc.c
+++ b/mm/vmalloc.c
-@@ -2774,6 +2774,8 @@ static const struct file_operations proc
+@@ -2783,6 +2783,8 @@ static const struct file_operations proc
static int __init proc_vmalloc_init(void)
{
diff --git a/target/linux/x86/64/config-default b/target/linux/x86/64/config-default
index ee14a36573..f4569c4214 100644
--- a/target/linux/x86/64/config-default
+++ b/target/linux/x86/64/config-default
@@ -221,6 +221,7 @@ CONFIG_INTEL_SOC_DTS_THERMAL=y
# CONFIG_IOMMU_DEBUG is not set
CONFIG_IOSF_MBI=y
# CONFIG_IOSF_MBI_DEBUG is not set
+# CONFIG_ISCSI_IBFT is not set
# CONFIG_ISCSI_IBFT_FIND is not set
CONFIG_KALLSYMS_ABSOLUTE_PERCPU=y
# CONFIG_KVM_DEBUG_FS is not set
diff --git a/target/linux/x86/generic/config-default b/target/linux/x86/generic/config-default
index 1e7cea801f..1e32581848 100644
--- a/target/linux/x86/generic/config-default
+++ b/target/linux/x86/generic/config-default
@@ -217,6 +217,7 @@ CONFIG_IRQ_BYPASS_MANAGER=y
CONFIG_ISA=y
CONFIG_ISAPNP=y
CONFIG_ISA_BUS_API=y
+# CONFIG_ISCSI_IBFT is not set
# CONFIG_ISCSI_IBFT_FIND is not set
CONFIG_ISO9660_FS=y
# CONFIG_JOLIET is not set
diff --git a/target/linux/x86/geode/config-default b/target/linux/x86/geode/config-default
index abca7ac6b8..2861c2bc35 100644
--- a/target/linux/x86/geode/config-default
+++ b/target/linux/x86/geode/config-default
@@ -74,6 +74,7 @@ CONFIG_IOSF_MBI=y
CONFIG_ISA=y
# CONFIG_ISAPNP is not set
CONFIG_ISA_BUS_API=y
+# CONFIG_ISCSI_IBFT is not set
# CONFIG_ISCSI_IBFT_FIND is not set
# CONFIG_LANCE is not set
CONFIG_LEDS_GPIO=y
diff --git a/target/linux/x86/legacy/config-default b/target/linux/x86/legacy/config-default
index d1a4e81035..60191c935c 100644
--- a/target/linux/x86/legacy/config-default
+++ b/target/linux/x86/legacy/config-default
@@ -137,6 +137,7 @@ CONFIG_IOSF_MBI=y
CONFIG_ISA=y
CONFIG_ISAPNP=y
CONFIG_ISA_BUS_API=y
+# CONFIG_ISCSI_IBFT is not set
# CONFIG_ISCSI_IBFT_FIND is not set
CONFIG_ISO9660_FS=y
# CONFIG_JOLIET is not set