aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/image-commands.mk4
-rw-r--r--target/linux/ar71xx/image/generic.mk4
2 files changed, 4 insertions, 4 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 63539bad08..49138a216d 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -102,6 +102,10 @@ define Build/append-squashfs-fakeroot-be
cat $@.fakesquashfs >> $@
endef
+define Build/append-string
+ echo -n $(1) >> $@
+endef
+
# append a fake/empty uImage header, to fool bootloaders rootfs integrity check
# for example
define Build/append-uImage-fakehdr
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index 05428039d3..45c6d75399 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -12,10 +12,6 @@ define Build/append-md5sum-bin
xargs echo -ne >> $@
endef
-define Build/append-string
- echo -n $(1) >> $@
-endef
-
define Build/mkwrggimg
$(STAGING_DIR_HOST)/bin/mkwrggimg -b \
-i $@ -o $@.imghdr -d /dev/mtdblock/1 \