aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/image-commands.mk7
1 files changed, 5 insertions, 2 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 1d0aed1918..5dfd6a2c2f 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -109,10 +109,13 @@ endef
# append a fake/empty uImage header, to fool bootloaders rootfs integrity check
# for example
define Build/append-uImage-fakehdr
+ $(eval type=$(word 1,$(1)))
+ $(eval magic=$(word 2,$(1)))
touch $@.fakehdr
$(STAGING_DIR_HOST)/bin/mkimage \
- -A $(LINUX_KARCH) -O linux -T $(1) -C none \
- -n '$(VERSION_DIST) fake $(1)' \
+ -A $(LINUX_KARCH) -O linux -T $(type) -C none \
+ -n '$(VERSION_DIST) fake $(type)' \
+ $(if $(magic),-M $(magic)) \
-d $@.fakehdr \
-s \
$@.fakehdr