aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xtarget/linux/ath79/base-files/etc/board.d/01_leds2
-rw-r--r--target/linux/ath79/dts/ar7241_ubnt_nanostation-m.dts (renamed from target/linux/ath79/dts/ar7241_ubnt_nano-m.dts)2
-rw-r--r--target/linux/ath79/image/generic-ubnt.mk7
3 files changed, 6 insertions, 5 deletions
diff --git a/target/linux/ath79/base-files/etc/board.d/01_leds b/target/linux/ath79/base-files/etc/board.d/01_leds
index 0b0dda3bcf..db5a6a4578 100755
--- a/target/linux/ath79/base-files/etc/board.d/01_leds
+++ b/target/linux/ath79/base-files/etc/board.d/01_leds
@@ -155,7 +155,7 @@ tplink,tl-wr841-v11)
;;
ubnt,bullet-m|\
ubnt,bullet-m-xw|\
-ubnt,nano-m|\
+ubnt,nanostation-m|\
ubnt,nanostation-m-xw|\
ubnt,rocket-m)
ucidef_set_rssimon "wlan0" "200000" "1"
diff --git a/target/linux/ath79/dts/ar7241_ubnt_nano-m.dts b/target/linux/ath79/dts/ar7241_ubnt_nanostation-m.dts
index ebdc4306e5..eebe65e53f 100644
--- a/target/linux/ath79/dts/ar7241_ubnt_nano-m.dts
+++ b/target/linux/ath79/dts/ar7241_ubnt_nanostation-m.dts
@@ -4,6 +4,6 @@
#include "ar7241_ubnt_xm_outdoor.dtsi"
/ {
- compatible = "ubnt,nano-m", "ubnt,xm", "qca,ar7241";
+ compatible = "ubnt,nanostation-m", "ubnt,xm", "qca,ar7241";
model = "Ubiquiti Nanostation M";
};
diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index 89b9f6746d..b7e867d8bf 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -106,16 +106,17 @@ define Device/ubnt_rocket-m
endef
TARGET_DEVICES += ubnt_rocket-m
-define Device/ubnt_nano-m
+define Device/ubnt_nanostation-m
$(Device/ubnt-xm)
- DEVICE_TITLE := Ubiquiti Nano-M
+ DEVICE_TITLE := Ubiquiti Nanostation M
SUPPORTED_DEVICES += nano-m
endef
-TARGET_DEVICES += ubnt_nano-m
+TARGET_DEVICES += ubnt_nanostation-m
define Device/ubnt_nanostation-m-xw
$(Device/ubnt-xw)
DEVICE_TITLE := Ubiquiti Nanostation M (XW)
+ SUPPORTED_DEVICES += nano-m-xw
endef
TARGET_DEVICES += ubnt_nanostation-m-xw