aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/kernel/linux/modules/other.mk2
-rw-r--r--target/linux/generic/config-4.192
2 files changed, 2 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 68e9366b5c..2fdb704556 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -900,7 +900,7 @@ define KernelPackage/random-tpm
TITLE:=Hardware Random Number Generator TPM support
KCONFIG:=CONFIG_HW_RANDOM_TPM
FILES:=$(LINUX_DIR)/drivers/char/hw_random/tpm-rng.ko
- DEPENDS:= +kmod-random-core +kmod-tpm
+ DEPENDS:= +kmod-random-core +kmod-tpm @!LINUX_4_19
AUTOLOAD:=$(call AutoProbe,tpm-rng)
endef
diff --git a/target/linux/generic/config-4.19 b/target/linux/generic/config-4.19
index b290e90db0..7171c2e478 100644
--- a/target/linux/generic/config-4.19
+++ b/target/linux/generic/config-4.19
@@ -1812,7 +1812,7 @@ CONFIG_HW_PERF_EVENTS=y
# CONFIG_HW_RANDOM_OMAP3_ROM is not set
# CONFIG_HW_RANDOM_PPC4XX is not set
# CONFIG_HW_RANDOM_TIMERIOMEM is not set
-# CONFIG_HW_RANDOM_TPM is not set
+CONFIG_HW_RANDOM_TPM=y
# CONFIG_HW_RANDOM_VIA is not set
# CONFIG_HW_RANDOM_VIRTIO is not set
# CONFIG_HX711 is not set