aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/boot/yamonenv/Makefile41
-rw-r--r--package/boot/yamonenv/patches/001-yamonenv_mtd_partition.patch11
-rw-r--r--target/linux/au1000/Makefile32
-rw-r--r--target/linux/au1000/au1500/config-default5
-rw-r--r--target/linux/au1000/au1500/profiles/Atheros.mk13
-rw-r--r--target/linux/au1000/au1500/profiles/InternetBox.mk18
-rw-r--r--target/linux/au1000/au1500/profiles/MeshCube.mk18
-rw-r--r--target/linux/au1000/au1500/target.mk5
-rw-r--r--target/linux/au1000/au1550/config-default4
-rw-r--r--target/linux/au1000/au1550/profiles/DBAu1550.mk13
-rw-r--r--target/linux/au1000/au1550/target.mk6
-rw-r--r--target/linux/au1000/base-files/etc/diag.sh21
-rw-r--r--target/linux/au1000/base-files/lib/upgrade/platform.sh26
-rw-r--r--target/linux/au1000/config-3.18140
-rw-r--r--target/linux/au1000/image/Makefile74
-rw-r--r--target/linux/au1000/modules.mk17
-rw-r--r--target/linux/au1000/patches-3.18/002-openwrt_rootfs.patch11
-rw-r--r--target/linux/au1000/patches-3.18/003-au1000_eth_ioctl.patch17
-rw-r--r--target/linux/au1000/patches-3.18/004-watchdog_low_init.patch12
-rw-r--r--target/linux/au1000/patches-3.18/006-codec.patch26
20 files changed, 0 insertions, 510 deletions
diff --git a/package/boot/yamonenv/Makefile b/package/boot/yamonenv/Makefile
deleted file mode 100644
index ef1f36de65..0000000000
--- a/package/boot/yamonenv/Makefile
+++ /dev/null
@@ -1,41 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=yamonenv
-PKG_VERSION:=20051022
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)_gruen.4g__$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://downloads.openwrt.org/sources
-PKG_HASH:=466eca9cdad2c15e957fb9ce7d0b6927ecd17d85c4cc2dff37e97a3e6b209c67
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
-
-PKG_FLAGS:=nonshared
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/yamonenv
- SECTION:=utils
- CATEGORY:=Utilities
- SUBMENU:=Boot Loaders
- DEPENDS:=@TARGET_au1000
- TITLE:=YAMON configuration utility
- MAINTAINER:=Florian Fainelli <florian@openwrt.org>
-endef
-
-define Build/Configure
-endef
-
-define Package/yamonenv/install
- $(INSTALL_DIR) $(1)/usr/sbin
- $(CP) $(PKG_BUILD_DIR)/src/$(PKG_NAME) $(1)/usr/sbin/
-endef
-
-$(eval $(call BuildPackage,yamonenv))
diff --git a/package/boot/yamonenv/patches/001-yamonenv_mtd_partition.patch b/package/boot/yamonenv/patches/001-yamonenv_mtd_partition.patch
deleted file mode 100644
index e1def28af5..0000000000
--- a/package/boot/yamonenv/patches/001-yamonenv_mtd_partition.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src/yamonenv.c
-+++ b/src/yamonenv.c
-@@ -12,7 +12,7 @@
- #include <fcntl.h>
- #include <unistd.h>
-
--#define DEFAULT_YAMON_ENV_FILE "/dev/mtd/3"
-+#define DEFAULT_YAMON_ENV_FILE "/dev/mtd3"
-
-
- // control byte definitions:
diff --git a/target/linux/au1000/Makefile b/target/linux/au1000/Makefile
deleted file mode 100644
index 3a79b4c316..0000000000
--- a/target/linux/au1000/Makefile
+++ /dev/null
@@ -1,32 +0,0 @@
-#
-# Copyright (C) 2006-2011 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-include $(TOPDIR)/rules.mk
-
-ARCH:=mipsel
-BOARD:=au1000
-BOARDNAME:=RMI/AMD AU1x00
-FEATURES:=squashfs usb pci small_flash source-only
-SUBTARGETS:=au1500 au1550
-MAINTAINER:=Florian Fainelli <florian@openwrt.org>
-
-KERNEL_PATCHVER:=3.18
-
-define Target/Description
- Build firmware for RMI/AMD Alchemy 1500,1550 boards
- (e.g. 4G-Systems Mesh/Access Cube, DBAu1550 ...)
-endef
-
-include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += wpad-mini yamonenv
-
-define Kernel/BuildImage
- $(call Kernel/BuildImage/Default)
- $(CP) $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.flash.srec $(LINUX_DIR)/zImage.flash.srec
- $(CP) $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.srec $(LINUX_DIR)/zImage.srec
-endef
-
-$(eval $(call BuildTarget))
diff --git a/target/linux/au1000/au1500/config-default b/target/linux/au1000/au1500/config-default
deleted file mode 100644
index 0289d967bb..0000000000
--- a/target/linux/au1000/au1500/config-default
+++ /dev/null
@@ -1,5 +0,0 @@
-CONFIG_DMA_NONCOHERENT=y
-# CONFIG_MIPS_DB1550 is not set
-CONFIG_MIPS_MTX1=y
-CONFIG_NEED_DMA_MAP_STATE=y
-CONFIG_WDT_MTX1=y
diff --git a/target/linux/au1000/au1500/profiles/Atheros.mk b/target/linux/au1000/au1500/profiles/Atheros.mk
deleted file mode 100644
index 75e8e108fb..0000000000
--- a/target/linux/au1000/au1500/profiles/Atheros.mk
+++ /dev/null
@@ -1,13 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Atheros
- NAME:=Atheros WiFi (default)
- PACKAGES:=kmod-ath5k
-endef
-$(eval $(call Profile,Atheros))
-
diff --git a/target/linux/au1000/au1500/profiles/InternetBox.mk b/target/linux/au1000/au1500/profiles/InternetBox.mk
deleted file mode 100644
index a73f0ce9af..0000000000
--- a/target/linux/au1000/au1500/profiles/InternetBox.mk
+++ /dev/null
@@ -1,18 +0,0 @@
-#
-# Copyright (C) 2007-2008 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/InternetBox
- NAME:=T-Mobile "InternetBox"
- PACKAGES:=kmod-ath5k kmod-usb-core kmod-usb-ohci kmod-usb-serial kmod-usb-serial-option \
- comgt
-endef
-
-define Profile/InternetBox/Description
- Package set for the T-Mobile "InternetBox" (TMD SB1-S)
-endef
-
-$(eval $(call Profile,InternetBox))
diff --git a/target/linux/au1000/au1500/profiles/MeshCube.mk b/target/linux/au1000/au1500/profiles/MeshCube.mk
deleted file mode 100644
index 969a3bbff7..0000000000
--- a/target/linux/au1000/au1500/profiles/MeshCube.mk
+++ /dev/null
@@ -1,18 +0,0 @@
-#
-# Copyright (C) 2007-2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/MeshCube
- NAME:=MeshCube MTX-1
- PACKAGES:=kmod-ath5k kmod-net-prism54 \
- kmod-usb-core kmod-usb-ohci kmod-usb-storage kmod-fs-ext4 kmod-fs-vfat
-endef
-
-define Profile/MeshCube/Description
- Package set for the 4G MeshCube (MTX-1)
-endef
-
-$(eval $(call Profile,MeshCube))
diff --git a/target/linux/au1000/au1500/target.mk b/target/linux/au1000/au1500/target.mk
deleted file mode 100644
index 3e9c5955ff..0000000000
--- a/target/linux/au1000/au1500/target.mk
+++ /dev/null
@@ -1,5 +0,0 @@
-BOARDNAME:=Au1500
-
-define Target/Description
- Build firmware images for Au1500 based boards
-endef
diff --git a/target/linux/au1000/au1550/config-default b/target/linux/au1000/au1550/config-default
deleted file mode 100644
index 2c641b8cab..0000000000
--- a/target/linux/au1000/au1550/config-default
+++ /dev/null
@@ -1,4 +0,0 @@
-CONFIG_DMA_COHERENT=y
-CONFIG_MIPS_DB1550=y
-CONFIG_MIPS_DISABLE_OBSOLETE_IDE=y
-# CONFIG_MIPS_MTX1 is not set
diff --git a/target/linux/au1000/au1550/profiles/DBAu1550.mk b/target/linux/au1000/au1550/profiles/DBAu1550.mk
deleted file mode 100644
index 3535be623e..0000000000
--- a/target/linux/au1000/au1550/profiles/DBAu1550.mk
+++ /dev/null
@@ -1,13 +0,0 @@
-#
-# Copyright (C) 2009-2015 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/DBAu1550
- NAME:=AMD DBAu1550 Development Kit
- PACKAGES:=kmod-pcmcia-au1000 kmod-usb-ohci kmod-usb2-pci
-endef
-
-$(eval $(call Profile,DBAu1550))
diff --git a/target/linux/au1000/au1550/target.mk b/target/linux/au1000/au1550/target.mk
deleted file mode 100644
index 9ed4468f30..0000000000
--- a/target/linux/au1000/au1550/target.mk
+++ /dev/null
@@ -1,6 +0,0 @@
-BOARDNAME:=Au1550
-FEATURES += pcmcia
-
-define Target/Description
- Build firmware images for Au1550 based boards
-endef
diff --git a/target/linux/au1000/base-files/etc/diag.sh b/target/linux/au1000/base-files/etc/diag.sh
deleted file mode 100644
index 65e3011be5..0000000000
--- a/target/linux/au1000/base-files/etc/diag.sh
+++ /dev/null
@@ -1,21 +0,0 @@
-#!/bin/sh
-# Copyright (C) 2007-2013 OpenWrt.org
-
-. /lib/functions/leds.sh
-
-set_state() {
- case "$1" in
- preinit)
- led_off "mtx1:green"
- led_on "mtx1:red"
- ;;
- failsafe)
- led_on "mtx1:green"
- led_on "mtx1:red"
- ;;
- done)
- led_on "mtx1:green"
- led_off "mtx1:red"
- ;;
- esac
-}
diff --git a/target/linux/au1000/base-files/lib/upgrade/platform.sh b/target/linux/au1000/base-files/lib/upgrade/platform.sh
deleted file mode 100644
index 7beb4a0d06..0000000000
--- a/target/linux/au1000/base-files/lib/upgrade/platform.sh
+++ /dev/null
@@ -1,26 +0,0 @@
-KERNEL_IMG="openwrt-au1000-au1500-vmlinux.bin"
-ROOTFS_IMG="openwrt-au1000-au1500-root.fs"
-
-platform_check_image() {
- [ "$#" -gt 1 ] && return 1
- case "$(get_magic_word "$1")" in
- 6f70)
- ( get_image "$1" | tar -tf - $KERNEL_IMG >/dev/null && \
- get_image "$1" | tar -tf - $ROOTFS_IMG >/dev/null) || {
- echo "Invalid image contents"
- return 1
- }
- return 0;;
- *)
- echo "Invalid image type"
- return 1;;
- esac
-}
-
-platform_do_upgrade() {
- sync
- local conf=""
- [ -f "$CONF_TAR" -a "$SAVE_CONFIG" -eq 1 ] && conf="-j $CONF_TAR"
- get_image "$1" | tar -Oxvf - $KERNEL_IMG | mtd write - "kernel"
- get_image "$1" | tar -Oxvf - $ROOTFS_IMG | mtd $conf write - "rootfs"
-}
diff --git a/target/linux/au1000/config-3.18 b/target/linux/au1000/config-3.18
deleted file mode 100644
index abce20a6ad..0000000000
--- a/target/linux/au1000/config-3.18
+++ /dev/null
@@ -1,140 +0,0 @@
-CONFIG_64BIT_PHYS_ADDR=y
-CONFIG_ALCHEMY_GPIOINT_AU1000=y
-CONFIG_ARCH_BINFMT_ELF_RANDOMIZE_PIE=y
-CONFIG_ARCH_DISCARD_MEMBLOCK=y
-CONFIG_ARCH_HAS_ATOMIC64_DEC_IF_POSITIVE=y
-CONFIG_ARCH_HAVE_CUSTOM_GPIO_H=y
-CONFIG_ARCH_HIBERNATION_POSSIBLE=y
-CONFIG_ARCH_MIGHT_HAVE_PC_PARPORT=y
-CONFIG_ARCH_MIGHT_HAVE_PC_SERIO=y
-CONFIG_ARCH_PHYS_ADDR_T_64BIT=y
-CONFIG_ARCH_REQUIRE_GPIOLIB=y
-CONFIG_ARCH_SUSPEND_POSSIBLE=y
-CONFIG_ARCH_WANT_IPC_PARSE_VERSION=y
-CONFIG_CEVT_R4K=y
-CONFIG_CLONE_BACKWARDS=y
-CONFIG_CMDLINE="console=ttyS0,115200 root=/dev/mtdblock0 rootfstype=squashfs,jffs2"
-CONFIG_CMDLINE_BOOL=y
-# CONFIG_CMDLINE_OVERRIDE is not set
-# CONFIG_CPU_BIG_ENDIAN is not set
-CONFIG_CPU_GENERIC_DUMP_TLB=y
-CONFIG_CPU_HAS_PREFETCH=y
-CONFIG_CPU_HAS_SYNC=y
-CONFIG_CPU_LITTLE_ENDIAN=y
-CONFIG_CPU_MIPS32=y
-CONFIG_CPU_MIPS32_R1=y
-CONFIG_CPU_MIPSR1=y
-CONFIG_CPU_R4K_CACHE_TLB=y
-CONFIG_CPU_R4K_FPU=y
-CONFIG_CPU_SUPPORTS_32BIT_KERNEL=y
-CONFIG_CPU_SUPPORTS_HIGHMEM=y
-CONFIG_CRC16=y
-CONFIG_CSRC_R4K=y
-CONFIG_DMA_NONCOHERENT=y
-CONFIG_EARLY_PRINTK=y
-CONFIG_GENERIC_ATOMIC64=y
-CONFIG_GENERIC_CLOCKEVENTS=y
-CONFIG_GENERIC_CLOCKEVENTS_BUILD=y
-CONFIG_GENERIC_CMOS_UPDATE=y
-CONFIG_GENERIC_IO=y
-CONFIG_GENERIC_IRQ_SHOW=y
-CONFIG_GENERIC_PCI_IOMAP=y
-CONFIG_GENERIC_SMP_IDLE_THREAD=y
-CONFIG_GPIOLIB=y
-CONFIG_GPIO_DEVRES=y
-CONFIG_HARDWARE_WATCHPOINTS=y
-CONFIG_HAS_DMA=y
-CONFIG_HAS_IOMEM=y
-CONFIG_HAS_IOPORT=y
-# CONFIG_HAVE_64BIT_ALIGNED_ACCESS is not set
-CONFIG_HAVE_ARCH_JUMP_LABEL=y
-CONFIG_HAVE_ARCH_KGDB=y
-CONFIG_HAVE_ARCH_TRACEHOOK=y
-# CONFIG_HAVE_BOOTMEM_INFO_NODE is not set
-CONFIG_HAVE_CC_STACKPROTECTOR=y
-CONFIG_HAVE_CONTEXT_TRACKING=y
-CONFIG_HAVE_C_RECORDMCOUNT=y
-CONFIG_HAVE_DEBUG_KMEMLEAK=y
-CONFIG_HAVE_DEBUG_STACKOVERFLOW=y
-CONFIG_HAVE_DMA_API_DEBUG=y
-CONFIG_HAVE_DMA_ATTRS=y
-CONFIG_HAVE_DYNAMIC_FTRACE=y
-CONFIG_HAVE_FTRACE_MCOUNT_RECORD=y
-CONFIG_HAVE_FUNCTION_GRAPH_TRACER=y
-CONFIG_HAVE_FUNCTION_TRACER=y
-CONFIG_HAVE_FUNCTION_TRACE_MCOUNT_TEST=y
-CONFIG_HAVE_GENERIC_DMA_COHERENT=y
-CONFIG_HAVE_IDE=y
-CONFIG_HAVE_KERNEL_BZIP2=y
-CONFIG_HAVE_KERNEL_GZIP=y
-CONFIG_HAVE_KERNEL_LZ4=y
-CONFIG_HAVE_KERNEL_LZMA=y
-CONFIG_HAVE_KERNEL_LZO=y
-CONFIG_HAVE_KERNEL_XZ=y
-CONFIG_HAVE_MEMBLOCK=y
-CONFIG_HAVE_MEMBLOCK_NODE_MAP=y
-CONFIG_HAVE_MOD_ARCH_SPECIFIC=y
-CONFIG_HAVE_NET_DSA=y
-CONFIG_HAVE_OPROFILE=y
-CONFIG_HAVE_PERF_EVENTS=y
-CONFIG_HAVE_SYSCALL_TRACEPOINTS=y
-CONFIG_HW_HAS_PCI=y
-CONFIG_HW_RANDOM=y
-CONFIG_HZ=250
-# CONFIG_HZ_100 is not set
-CONFIG_HZ_250=y
-CONFIG_HZ_PERIODIC=y
-CONFIG_INITRAMFS_SOURCE=""
-CONFIG_IRQ_CPU=y
-CONFIG_IRQ_FORCED_THREADING=y
-CONFIG_IRQ_WORK=y
-CONFIG_KEXEC=y
-CONFIG_LEDS_GPIO=y
-CONFIG_MAGIC_SYSRQ=y
-CONFIG_MDIO_BOARDINFO=y
-CONFIG_MIPS=y
-CONFIG_MIPS_ALCHEMY=y
-CONFIG_MIPS_AU1X00_ENET=y
-CONFIG_MIPS_DB1000=y
-# CONFIG_MIPS_DB1XXX is not set
-# CONFIG_MIPS_DB1235 is not set
-# CONFIG_MIPS_GPR is not set
-# CONFIG_MIPS_HUGE_TLB_SUPPORT is not set
-CONFIG_MIPS_L1_CACHE_SHIFT=5
-# CONFIG_MIPS_MACHINE is not set
-# CONFIG_MIPS_MTX1 is not set
-CONFIG_MIPS_MT_DISABLED=y
-# CONFIG_MIPS_XXS1500 is not set
-CONFIG_MODULES_USE_ELF_REL=y
-CONFIG_MODULE_FORCE_UNLOAD=y
-# CONFIG_MTD_CFI_INTELEXT is not set
-# CONFIG_MTD_COMPLEX_MAPPINGS is not set
-CONFIG_MTD_PHYSMAP=y
-CONFIG_NEED_DMA_MAP_STATE=y
-CONFIG_NEED_PER_CPU_KM=y
-CONFIG_NO_GENERIC_PCI_IOPORT_MAP=y
-CONFIG_PAGEFLAGS_EXTENDED=y
-CONFIG_PCI=y
-CONFIG_PCI_DOMAINS=y
-CONFIG_PERF_USE_VMALLOC=y
-CONFIG_PHYLIB=y
-CONFIG_PHYS_ADDR_T_64BIT=y
-# CONFIG_PREEMPT_RCU is not set
-# CONFIG_PREVENT_FIRMWARE_BUILD is not set
-# CONFIG_RCU_STALL_COMMON is not set
-# CONFIG_SCSI_DMA is not set
-CONFIG_SERIAL_8250_NR_UARTS=4
-CONFIG_SERIAL_8250_RUNTIME_UARTS=4
-# CONFIG_STANDALONE is not set
-CONFIG_SYS_HAS_CPU_MIPS32_R1=y
-CONFIG_SYS_HAS_EARLY_PRINTK=y
-CONFIG_SYS_SUPPORTS_32BIT_KERNEL=y
-CONFIG_SYS_SUPPORTS_APM_EMULATION=y
-CONFIG_SYS_SUPPORTS_ARBIT_HZ=y
-CONFIG_SYS_SUPPORTS_BIG_ENDIAN=y
-CONFIG_SYS_SUPPORTS_LITTLE_ENDIAN=y
-CONFIG_SYS_SUPPORTS_ZBOOT=y
-CONFIG_TICK_CPU_ACCOUNTING=y
-CONFIG_USB_SUPPORT=y
-CONFIG_WATCHDOG_CORE=y
-CONFIG_ZONE_DMA_FLAG=0
diff --git a/target/linux/au1000/image/Makefile b/target/linux/au1000/image/Makefile
deleted file mode 100644
index 744e5c64e9..0000000000
--- a/target/linux/au1000/image/Makefile
+++ /dev/null
@@ -1,74 +0,0 @@
-#
-# Copyright (C) 2006-2010 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-JFFS2_BLOCKSIZE = 128k
-
-include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/image.mk
-
-LOADADDR = 0x81000000 # RAM start + 16M
-KERNEL_ENTRY = 0x80100000
-RAMSIZE = 0x00100000 # 1MB
-
-FLASH_KERNEL := 0xBFD00000
-FLASH_FS := 0xBE000000
-
-LOADER_MAKEOPTS= \
- KDIR=$(KDIR) \
- LOADADDR=$(LOADADDR) \
- KERNEL_ENTRY=$(KERNEL_ENTRY) \
- RAMSIZE=$(RAMSIZE)
-
-define Build/Clean
- $(MAKE) -C $(GENERIC_PLATFORM_DIR)/image/lzma-loader $(LOADER_MAKEOPTS) clean
-endef
-
-DROP_SECTIONS := .reginfo .mdebug .comment .note .pdr .options .MIPS.options
-OBJCOPY_SREC := $(TARGET_CROSS)objcopy -S -O srec $(addprefix --remove-section=,$(DROP_SECTIONS))
-OBJCOPY_BIN := $(TARGET_CROSS)objcopy -S -O binary $(addprefix --remove-section=,$(DROP_SECTIONS))
-
-define Image/Prepare
- cat $(KDIR)/vmlinux | $(STAGING_DIR_HOST)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $(KDIR)/vmlinux.lzma
-
- # Build RAM image
- $(MAKE) -C $(GENERIC_PLATFORM_DIR)/image/lzma-loader \
- $(LOADER_MAKEOPTS) \
- clean compile
- $(OBJCOPY_SREC) $(KDIR)/loader.elf $(KDIR)/kernel.ram.srec
-
- # Build Flash image
- $(MAKE) -C $(GENERIC_PLATFORM_DIR)/image/lzma-loader \
- $(LOADER_MAKEOPTS) \
- IMAGE_COPY=1 \
- LOADER_ENTRY=$(FLASH_KERNEL) \
- LOADER_TYPE=_flash \
- clean compile
- $(OBJCOPY_SREC) $(KDIR)/loader_flash.elf $(KDIR)/kernel.flash.srec
- $(OBJCOPY_BIN) $(KDIR)/loader_flash.elf $(KDIR)/kernel.flash.bin
-endef
-
-define Image/Build/Initramfs
- $(OBJCOPY_SREC) $(KDIR)/vmlinux-initramfs.elf $(BIN_DIR)/$(IMG_PREFIX)-vmlinux-initramfs.srec
-endef
-
-define Image/Build
- $(SCRIPT_DIR)/srecimage.pl $(KDIR)/root.$(1) $(KDIR)/root.$(1).srec $(FLASH_FS)
- grep -v S7 $(KDIR)/root.$(1).srec > $(BIN_DIR)/$(IMG_PREFIX)-$(1).srec
- grep -v S0 $(KDIR)/kernel.flash.srec >> $(BIN_DIR)/$(IMG_PREFIX)-$(1).srec
- $(INSTALL_BIN) $(KDIR)/kernel.flash.bin $(BIN_DIR)/$(IMG_PREFIX)-vmlinux.bin
- $(CP) $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-$(1).fs
- $(CP) $(KDIR)/kernel.flash.srec $(BIN_DIR)/$(IMG_PREFIX)-vmlinux-flash.srec
- $(CP) $(KDIR)/kernel.ram.srec $(BIN_DIR)/$(IMG_PREFIX)-vmlinux-ram.srec
- $(CP) $(BIN_DIR)/$(IMG_PREFIX)-$(1).fs $(TMP_DIR)/$(IMG_PREFIX)-root.fs
- tar -C $(BIN_DIR) -cvzf $(BIN_DIR)/$(IMG_PREFIX)-$(1)-sysupgrade.bin \
- $(IMG_PREFIX)-vmlinux.bin -C $(TMP_DIR) $(IMG_PREFIX)-root.fs
-ifeq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
- $(call Image/Build/Initramfs)
-endif
-endef
-
-$(eval $(call BuildImage))
diff --git a/target/linux/au1000/modules.mk b/target/linux/au1000/modules.mk
deleted file mode 100644
index 6b110531a5..0000000000
--- a/target/linux/au1000/modules.mk
+++ /dev/null
@@ -1,17 +0,0 @@
-#
-# Copyright (C) 2010-2015 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define KernelPackage/pcmcia-au1000
- SUBMENU:=$(PCMCIA_MENU)
- TITLE:=RMI/AMD Au1000 PCMCIA support
- DEPENDS:=@TARGET_au1000 +kmod-pcmcia-core +kmod-pcmcia-rsrc
- FILES:=$(LINUX_DIR)/drivers/pcmcia/db1xxx_ss.ko
- KCONFIG:=CONFIG_PCMCIA_ALCHEMY_DEVBOARD
- AUTOLOAD:=$(call AutoLoad,41,db1xxx_ss)
-endef
-
-$(eval $(call KernelPackage,pcmcia-au1000))
diff --git a/target/linux/au1000/patches-3.18/002-openwrt_rootfs.patch b/target/linux/au1000/patches-3.18/002-openwrt_rootfs.patch
deleted file mode 100644
index 1de8236547..0000000000
--- a/target/linux/au1000/patches-3.18/002-openwrt_rootfs.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/arch/mips/alchemy/board-mtx1.c
-+++ b/arch/mips/alchemy/board-mtx1.c
-@@ -169,7 +169,7 @@ static struct platform_device mtx1_gpio_
-
- static struct mtd_partition mtx1_mtd_partitions[] = {
- {
-- .name = "filesystem",
-+ .name = "rootfs",
- .size = 0x01C00000,
- .offset = 0,
- },
diff --git a/target/linux/au1000/patches-3.18/003-au1000_eth_ioctl.patch b/target/linux/au1000/patches-3.18/003-au1000_eth_ioctl.patch
deleted file mode 100644
index 58927f590d..0000000000
--- a/target/linux/au1000/patches-3.18/003-au1000_eth_ioctl.patch
+++ /dev/null
@@ -1,17 +0,0 @@
---- a/drivers/net/ethernet/amd/au1000_eth.c
-+++ b/drivers/net/ethernet/amd/au1000_eth.c
-@@ -1113,10 +1113,14 @@ static void au1000_multicast_list(struct
- writel(reg, &aup->mac->control);
- }
-
-+#define AU1000_KNOWN_PHY_IOCTLS (SIOCGMIIPHY & 0xfff0)
- static int au1000_ioctl(struct net_device *dev, struct ifreq *rq, int cmd)
- {
- struct au1000_private *aup = netdev_priv(dev);
-
-+ if((cmd & AU1000_KNOWN_PHY_IOCTLS) != AU1000_KNOWN_PHY_IOCTLS)
-+ return -EINVAL;
-+
- if (!netif_running(dev))
- return -EINVAL;
-
diff --git a/target/linux/au1000/patches-3.18/004-watchdog_low_init.patch b/target/linux/au1000/patches-3.18/004-watchdog_low_init.patch
deleted file mode 100644
index 09110408e5..0000000000
--- a/target/linux/au1000/patches-3.18/004-watchdog_low_init.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/arch/mips/alchemy/board-mtx1.c
-+++ b/arch/mips/alchemy/board-mtx1.c
-@@ -98,6 +98,9 @@ void __init board_setup(void)
- alchemy_gpio_direction_output(211, 1); /* green on */
- alchemy_gpio_direction_output(212, 0); /* red off */
-
-+ /* Set watchdog pin low */
-+ alchemy_gpio_direction_output(215, 0);
-+
- pm_power_off = mtx1_power_off;
- _machine_halt = mtx1_power_off;
- _machine_restart = mtx1_reset;
diff --git a/target/linux/au1000/patches-3.18/006-codec.patch b/target/linux/au1000/patches-3.18/006-codec.patch
deleted file mode 100644
index d80cf56ac9..0000000000
--- a/target/linux/au1000/patches-3.18/006-codec.patch
+++ /dev/null
@@ -1,26 +0,0 @@
---- a/arch/mips/alchemy/devboards/db1300.c
-+++ b/arch/mips/alchemy/devboards/db1300.c
-@@ -712,6 +712,7 @@ static struct platform_device db1300_lcd
-
- /**********************************************************************/
-
-+#ifdef CONFIG_TOUCHSCREEN_WM97XX
- static void db1300_wm97xx_irqen(struct wm97xx *wm, int enable)
- {
- if (enable)
-@@ -744,6 +745,15 @@ static int db1300_wm97xx_probe(struct pl
- return wm97xx_register_mach_ops(wm, &db1300_wm97xx_ops);
- }
-
-+#else
-+
-+static int db1300_wm97xx_probe(struct platform_device *pdev)
-+{
-+ return -1;
-+}
-+
-+#endif
-+
- static struct platform_driver db1300_wm97xx_driver = {
- .driver.name = "wm97xx-touch",
- .driver.owner = THIS_MODULE,