aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--toolchain/glibc/common.mk4
-rw-r--r--toolchain/glibc/patches/100-fix_cross_rpcgen.patch2
-rw-r--r--toolchain/glibc/patches/200-add-dl-search-paths.patch2
3 files changed, 4 insertions, 4 deletions
diff --git a/toolchain/glibc/common.mk b/toolchain/glibc/common.mk
index e57f811e48..a6bd6d5af5 100644
--- a/toolchain/glibc/common.mk
+++ b/toolchain/glibc/common.mk
@@ -11,8 +11,8 @@ PKG_VERSION:=2.26
PKG_SOURCE_PROTO:=git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=4df8479e6b3baf365bd4eedbba922b73471e5d73
-PKG_MIRROR_HASH:=8c9cb826cf5ec94c827b4edce7e6f809cb560d3164a43f01280e5469896b4717
+PKG_SOURCE_VERSION:=7b52c8ae05340c795654d23a0e7a2590a3e23bd2
+PKG_MIRROR_HASH:=f60f1a1dbb8f339d18ff36eb11b6e04cab853711919c71487b9e0604bbc16c10
PKG_SOURCE_URL:=https://sourceware.org/git/glibc.git
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.xz
diff --git a/toolchain/glibc/patches/100-fix_cross_rpcgen.patch b/toolchain/glibc/patches/100-fix_cross_rpcgen.patch
index 6a5e537b77..f10efcc5d6 100644
--- a/toolchain/glibc/patches/100-fix_cross_rpcgen.patch
+++ b/toolchain/glibc/patches/100-fix_cross_rpcgen.patch
@@ -38,7 +38,7 @@
+++ b/sunrpc/rpc_main.c
@@ -958,9 +958,10 @@ mkfile_output (struct commandline *cmd)
abort ();
- temp = rindex (cmd->infile, '.');
+ temp = strrchr (cmd->infile, '.');
cp = stpcpy (mkfilename, "Makefile.");
- if (temp != NULL)
- *((char *) stpncpy (cp, cmd->infile, temp - cmd->infile)) = '\0';
diff --git a/toolchain/glibc/patches/200-add-dl-search-paths.patch b/toolchain/glibc/patches/200-add-dl-search-paths.patch
index 8f720cb9fd..5bd58dc8d5 100644
--- a/toolchain/glibc/patches/200-add-dl-search-paths.patch
+++ b/toolchain/glibc/patches/200-add-dl-search-paths.patch
@@ -2,7 +2,7 @@ add /usr/lib to default search path for the dynamic linker
--- a/Makeconfig
+++ b/Makeconfig
-@@ -571,6 +571,9 @@ else
+@@ -578,6 +578,9 @@ else
default-rpath = $(libdir)
endif