aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/kernel/linux/modules/netsupport.mk3
1 files changed, 1 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index 07ce47992c..c9740a945c 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -865,7 +865,6 @@ $(eval $(call KernelPackage,l2tp-ip))
define KernelPackage/sctp
SUBMENU:=$(NETWORK_SUPPORT_MENU)
TITLE:=SCTP protocol kernel support
- DEPENDS:=+IPV6:kmod-ipv6
KCONFIG:=\
CONFIG_IP_SCTP \
CONFIG_SCTP_DBG_MSG=n \
@@ -880,7 +879,7 @@ define KernelPackage/sctp
CONFIG_SCTP_DEFAULT_COOKIE_HMAC_MD5=y
FILES:= $(LINUX_DIR)/net/sctp/sctp.ko
AUTOLOAD:= $(call AutoLoad,32,sctp)
- DEPENDS:=+kmod-lib-crc32c +kmod-crypto-md5 +kmod-crypto-hmac
+ DEPENDS:=+kmod-lib-crc32c +kmod-crypto-md5 +kmod-crypto-hmac +IPV6:kmod-ipv6
endef
define KernelPackage/sctp/description