aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/linux/lantiq/Makefile2
-rw-r--r--target/linux/lantiq/ase/config-default26
-rw-r--r--target/linux/lantiq/ase/profiles/00-default.mk9
-rw-r--r--target/linux/lantiq/ase/target.mk20
4 files changed, 56 insertions, 1 deletions
diff --git a/target/linux/lantiq/Makefile b/target/linux/lantiq/Makefile
index 3e4f48e7b1..a92e181bcf 100644
--- a/target/linux/lantiq/Makefile
+++ b/target/linux/lantiq/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
BOARD:=lantiq
BOARDNAME:=Lantiq
FEATURES:=squashfs
-SUBTARGETS:=xrx200 xway xway_legacy falcon
+SUBTARGETS:=xrx200 xway xway_legacy falcon ase
MAINTAINER:=John Crispin <john@phrozen.org>
KERNEL_PATCHVER:=4.4
diff --git a/target/linux/lantiq/ase/config-default b/target/linux/lantiq/ase/config-default
new file mode 100644
index 0000000000..b6cd4f3910
--- /dev/null
+++ b/target/linux/lantiq/ase/config-default
@@ -0,0 +1,26 @@
+CONFIG_ADM6996_PHY=y
+CONFIG_CC_OPTIMIZE_FOR_SIZE=y
+CONFIG_CPU_MIPS32_R1=y
+# CONFIG_CPU_MIPS32_R2 is not set
+CONFIG_CPU_MIPSR1=y
+CONFIG_CRC16=y
+CONFIG_CRYPTO_DEFLATE=y
+CONFIG_FIRMWARE_IN_KERNEL=y
+CONFIG_FIRMWARE_MEMMAP=y
+CONFIG_GPIO_GENERIC=y
+CONFIG_GPIO_GENERIC_PLATFORM=y
+CONFIG_HAVE_IRQ_EXIT_ON_IRQ_STACK=y
+# CONFIG_ISDN is not set
+# CONFIG_LBDAF is not set
+CONFIG_LEDS_TRIGGER_HEARTBEAT=y
+CONFIG_MIPS_FPU_EMULATOR=y
+# CONFIG_PSB6970_PHY is not set
+# CONFIG_RTL8366_SMI is not set
+CONFIG_SOC_AMAZON_SE=y
+# CONFIG_SOC_XWAY is not set
+# CONFIG_SPI is not set
+CONFIG_USB_SUPPORT=y
+# CONFIG_WIRELESS is not set
+# CONFIG_WLAN is not set
+CONFIG_ZLIB_DEFLATE=y
+CONFIG_ZLIB_INFLATE=y
diff --git a/target/linux/lantiq/ase/profiles/00-default.mk b/target/linux/lantiq/ase/profiles/00-default.mk
new file mode 100644
index 0000000000..26bc8b502b
--- /dev/null
+++ b/target/linux/lantiq/ase/profiles/00-default.mk
@@ -0,0 +1,9 @@
+define Profile/Default
+ NAME:=Default Profile
+ PRIORITY:=1
+endef
+
+define Profile/Default/Description
+ Default package set compatible with most boards.
+endef
+$(eval $(call Profile,Default))
diff --git a/target/linux/lantiq/ase/target.mk b/target/linux/lantiq/ase/target.mk
new file mode 100644
index 0000000000..5f6c03b38e
--- /dev/null
+++ b/target/linux/lantiq/ase/target.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2016 LEDE Project
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+ARCH:=mips
+SUBTARGET:=ase
+BOARDNAME:=Amazon-SE
+FEATURES:=squashfs atm mips16 small_flash
+CPU_TYPE:=mips32
+
+DEFAULT_PACKAGES+=kmod-leds-gpio kmod-gpio-button-hotplug \
+ kmod-ltq-adsl-ase kmod-ltq-adsl-ase-mei \
+ kmod-ltq-adsl-ase-fw-b kmod-ltq-atm-ase \
+ ltq-adsl-app ppp-mod-pppoe
+
+define Target/Description
+ Lantiq Amazon-SE Boards
+endef