aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/network/services/uhttpd/Makefile4
-rw-r--r--package/utils/ugps/Makefile4
2 files changed, 8 insertions, 0 deletions
diff --git a/package/network/services/uhttpd/Makefile b/package/network/services/uhttpd/Makefile
index 7c0989de1a..f4de987e65 100644
--- a/package/network/services/uhttpd/Makefile
+++ b/package/network/services/uhttpd/Makefile
@@ -107,6 +107,10 @@ define Package/uhttpd/conffiles
/etc/uhttpd.key
endef
+ifneq ($(CONFIG_USE_GLIBC),)
+ TARGET_CFLAGS += -D_DEFAULT_SOURCE
+endif
+
TARGET_LDFLAGS += -lcrypt
CMAKE_OPTIONS = -DTLS_SUPPORT=on
diff --git a/package/utils/ugps/Makefile b/package/utils/ugps/Makefile
index c1bc7cdd01..3662125c3a 100644
--- a/package/utils/ugps/Makefile
+++ b/package/utils/ugps/Makefile
@@ -32,6 +32,10 @@ endef
TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include
+ifneq ($(CONFIG_USE_GLIBC),)
+ TARGET_CFLAGS += -D_DEFAULT_SOURCE
+endif
+
define Package/ugps/install
$(INSTALL_DIR) $(1)/usr/sbin $(1)/etc/init.d $(1)/etc/config
$(INSTALL_BIN) $(PKG_BUILD_DIR)/ugps $(1)/usr/sbin/