aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/host-build.mk1
-rw-r--r--include/package-defaults.mk1
2 files changed, 2 insertions, 0 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index 72b32597d4..56e0e4e413 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -43,6 +43,7 @@ Host/Patch:=$(Host/Patch/Default)
ifneq ($(strip $(HOST_UNPACK)),)
define Host/Prepare/Default
$(HOST_UNPACK)
+ [ ! -d ./src/ ] || $(CP) ./src/* $(HOST_BUILD_DIR)
$(Host/Patch)
endef
endif
diff --git a/include/package-defaults.mk b/include/package-defaults.mk
index 4eb5409909..487811c0e2 100644
--- a/include/package-defaults.mk
+++ b/include/package-defaults.mk
@@ -62,6 +62,7 @@ Build/Patch:=$(Build/Patch/Default)
ifneq ($(strip $(PKG_UNPACK)),)
define Build/Prepare/Default
$(PKG_UNPACK)
+ [ ! -d ./src/ ] || $(CP) ./src/* $(PKG_BUILD_DIR)
$(Build/Patch)
endef
endif