aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/u-boot.mk5
-rw-r--r--package/boot/uboot-lantiq/Makefile2
2 files changed, 7 insertions, 0 deletions
diff --git a/include/u-boot.mk b/include/u-boot.mk
index 0c28653326..4b3ff69d6b 100644
--- a/include/u-boot.mk
+++ b/include/u-boot.mk
@@ -40,6 +40,11 @@ endef
TARGET_DEP = TARGET_$(BUILD_TARGET)$(if $(BUILD_SUBTARGET),_$(BUILD_SUBTARGET))
+UBOOT_MAKE_FLAGS = \
+ HOSTCC="$(HOSTCC)" \
+ HOSTCFLAGS='$(HOST_CFLAGS) $$$$(HOSTCPPFLAGS)' \
+ HOSTLDFLAGS=""
+
define Build/U-Boot/Target
$(eval $(call U-Boot/Init,$(1)))
$(eval $(call U-Boot/Default,$(1)))
diff --git a/package/boot/uboot-lantiq/Makefile b/package/boot/uboot-lantiq/Makefile
index b16e7cd2b1..94b604af34 100644
--- a/package/boot/uboot-lantiq/Makefile
+++ b/package/boot/uboot-lantiq/Makefile
@@ -366,6 +366,8 @@ define Build/Prepare
$(call CompressVR9Firmware,22f,2)
endef
+UBOOT_MAKE_FLAGS :=
+
ifeq ($(SUBTARGET),xway)
SOC:=danube
else