aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/generic/hack-4.14/902-debloat_proc.patch2
-rw-r--r--target/linux/x86/64/config-4.141
-rw-r--r--target/linux/x86/generic/config-4.141
-rw-r--r--target/linux/x86/geode/config-4.141
-rw-r--r--target/linux/x86/legacy/config-4.141
6 files changed, 7 insertions, 3 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index c03c8a369a..354b493236 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -7,11 +7,11 @@ ifdef CONFIG_TESTING_KERNEL
endif
LINUX_VERSION-4.9 = .189
-LINUX_VERSION-4.14 = .138
+LINUX_VERSION-4.14 = .139
LINUX_VERSION-4.19 = .66
LINUX_KERNEL_HASH-4.9.189 = 93d945661246f726b694455c80c140717d2beff5a718445a51183439bbe5d0b3
-LINUX_KERNEL_HASH-4.14.138 = f250bd1de3a83c1f015f8e6e9bfa9f20eaef3dc24a6cd60116e49979314b837b
+LINUX_KERNEL_HASH-4.14.139 = 8c62d495444dba90200740ec770d274780b010e957cfc447f07999d717e37042
LINUX_KERNEL_HASH-4.19.66 = c981abe15c4b9496cdadb04e4f4afb88b3a78f31ced8d07684ee9c58b3fadb64
remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
diff --git a/target/linux/generic/hack-4.14/902-debloat_proc.patch b/target/linux/generic/hack-4.14/902-debloat_proc.patch
index 2a20058ed3..aedefb32b4 100644
--- a/target/linux/generic/hack-4.14/902-debloat_proc.patch
+++ b/target/linux/generic/hack-4.14/902-debloat_proc.patch
@@ -232,7 +232,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
return -ENOMEM;
--- a/mm/vmalloc.c
+++ b/mm/vmalloc.c
-@@ -2774,6 +2774,8 @@ static const struct file_operations proc
+@@ -2783,6 +2783,8 @@ static const struct file_operations proc
static int __init proc_vmalloc_init(void)
{
diff --git a/target/linux/x86/64/config-4.14 b/target/linux/x86/64/config-4.14
index 85ddd6309b..b9777c0f72 100644
--- a/target/linux/x86/64/config-4.14
+++ b/target/linux/x86/64/config-4.14
@@ -274,6 +274,7 @@ CONFIG_INTEL_SOC_DTS_THERMAL=y
# CONFIG_IOMMU_DEBUG is not set
CONFIG_IOSF_MBI=y
# CONFIG_IOSF_MBI_DEBUG is not set
+# CONFIG_ISCSI_IBFT is not set
# CONFIG_ISCSI_IBFT_FIND is not set
CONFIG_KALLSYMS_ABSOLUTE_PERCPU=y
# CONFIG_KVM_DEBUG_FS is not set
diff --git a/target/linux/x86/generic/config-4.14 b/target/linux/x86/generic/config-4.14
index 92380f526d..1e31e117dd 100644
--- a/target/linux/x86/generic/config-4.14
+++ b/target/linux/x86/generic/config-4.14
@@ -214,6 +214,7 @@ CONFIG_IRQ_BYPASS_MANAGER=y
CONFIG_ISA=y
CONFIG_ISAPNP=y
CONFIG_ISA_BUS_API=y
+# CONFIG_ISCSI_IBFT is not set
# CONFIG_ISCSI_IBFT_FIND is not set
CONFIG_ISO9660_FS=y
# CONFIG_JOLIET is not set
diff --git a/target/linux/x86/geode/config-4.14 b/target/linux/x86/geode/config-4.14
index f75891cee7..796aba7cd2 100644
--- a/target/linux/x86/geode/config-4.14
+++ b/target/linux/x86/geode/config-4.14
@@ -73,6 +73,7 @@ CONFIG_IOSF_MBI=y
CONFIG_ISA=y
# CONFIG_ISAPNP is not set
CONFIG_ISA_BUS_API=y
+# CONFIG_ISCSI_IBFT is not set
# CONFIG_ISCSI_IBFT_FIND is not set
# CONFIG_LANCE is not set
CONFIG_LEDS_GPIO=y
diff --git a/target/linux/x86/legacy/config-4.14 b/target/linux/x86/legacy/config-4.14
index dab36d39fc..6fa2d083ab 100644
--- a/target/linux/x86/legacy/config-4.14
+++ b/target/linux/x86/legacy/config-4.14
@@ -133,6 +133,7 @@ CONFIG_IOSF_MBI=y
CONFIG_ISA=y
CONFIG_ISAPNP=y
CONFIG_ISA_BUS_API=y
+# CONFIG_ISCSI_IBFT is not set
# CONFIG_ISCSI_IBFT_FIND is not set
CONFIG_ISO9660_FS=y
# CONFIG_JOLIET is not set