aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/unpack.mk9
1 files changed, 2 insertions, 7 deletions
diff --git a/include/unpack.mk b/include/unpack.mk
index a139827490..6141b1c722 100644
--- a/include/unpack.mk
+++ b/include/unpack.mk
@@ -58,18 +58,13 @@ ifeq ($(strip $(UNPACK_CMD)),)
UNPACK_CMD=gzip -dc $(DL_DIR)/$(PKG_SOURCE) | $(TAR_CMD)
endif
endif
- ifneq ($(strip $(CRLF_WORKAROUND)),)
- CRLF_CMD := && find $(PKG_BUILD_DIR) -type f -print0 | xargs -0 perl -pi -e 's!\r$$$$!!g'
- else
- CRLF_CMD :=
- endif
endif
ifdef PKG_BUILD_DIR
- PKG_UNPACK ?= $(SH_FUNC) $(call UNPACK_CMD,$(PKG_BUILD_DIR)) $(call CRLF_CMD,$(PKG_BUILD_DIR))
+ PKG_UNPACK ?= $(SH_FUNC) $(call UNPACK_CMD,$(PKG_BUILD_DIR))
endif
ifdef HOST_BUILD_DIR
- HOST_UNPACK ?= $(SH_FUNC) $(call UNPACK_CMD,$(HOST_BUILD_DIR)) $(call CRLF_CMD,$(HOST_BUILD_DIR))
+ HOST_UNPACK ?= $(SH_FUNC) $(call UNPACK_CMD,$(HOST_BUILD_DIR))
endif
endif # PKG_SOURCE